Emoncms errors after upgrade


Yesterday I updated my EmonPi in the first time for a long time. The process seemed to run through succesfully and all seemed well. This morning I have a laundry list of errors:

  • All of my feeds are marked as inactive and show no data
  • If I try and look at Inputs I get the following error message:

Fatal error: Class ‘Device’ not found in /var/www/emoncms/Modules/input/input_controller.php on line 37

  • On the admin page I get the following list of errors at the top of the page:

non-object in /var/www/emoncms/Modules/admin/admin_model.php on line 86

Notice : Trying to get property of non-object in /var/www/emoncms/Modules/admin/admin_model.php on line 85

Notice : Trying to get property of non-object in /var/www/emoncms/Modules/admin/admin_model.php on line 86

This is all on low-write 10.2.3.

I’m not sure where even to begin with troubleshooting this. I’ve tried rebooting, which made no difference, and searching the forums here and couldn’t find anything similar.

Does anyone have any suggestions as to where I can start with fixing this please?

Hi Ben, I’ll @TrystanLea. Do you know what the old version was?

Do you get anything on the Admin Page or just a list of errors?

Hi @borpin,

Rather stupidly I didn’t note it down. It was in the 9.x series somewhere I think.

The rest of the admin page displays after the errors. There was an error about emoncms.log not existing or not having the right permissions but I fixed that by following the supplied instructions.

Do you have a spare SD Card?

It is likely the Image was pretty old so the simplest (and best) way is to start afresh with a new image. You can easily migrate all of your old data.

No, but I can get one easily enough.

I’m not too worried about the data, most of that is stored in an off-system InfluxDB for later analysis. I am concerned with the config (inputs, feeds & that kind of thing) - does that transfer easily as well?

It should … :grinning:

Hello @xyleth, sorry to hear that the upgrade ended up in this state, as @borpin suggests, uploading the latest image to a new card is probably your best bet and then using the import method described here Update & Upgrade - Guide | OpenEnergyMonitor.

The latest SD card image is available to download here:
emonSD pre built SD card Download & Change Log · openenergymonitor/emonpi Wiki · GitHub

Hi Everyone,

So, an update. I ordered a new pre-loaded SD card from the store, which arrived promptly. As an aside you should really mention somewhere in the docs that changing the SD card requires removing the black end panel of the emonPi. If it is mentioned I couldn’t find it, and I spent quite a while looking.

Got the old card out, new card in. Reassembled the and rebooted. Connected via the web app fine, registered an admin account. Popped old SD card into a USB reader and connected to the emonPi as instructed.

Problem #1: The version of emoncms on the pre-loaded card doesn’t have the ‘restore from USB’ tab on the backup page as the documentation suggests. Oh well, run an upgrade to the latest version and the tab appears.

Go to run the import from USB process. A screen full of errors, all of which fly past far too quick to capture, and then the web application refuses to work anymore with an error relating to ‘unable to connect to database, check settings.ini’

Tried to troubleshoot that, didn’t really get anywhere. Managed to track down the factoryreset script, ran that and now everything has returned to where it was about an hour ago.

At this point I’ve given up on salvaging my previous config and will just re-build from scratch, which isn’t terrible for me as I’m not really concerned with the data. But I thought you’d like to know that the suggested approach really didn’t work.

Still broken.

Now when I try and create a feed I get the error:

ERROR: Feed could not be created, could not write meta data file fopen(/home/pi/data/phpfina/1.meta): failed to open stream: No such file or directory


Sorry to hear this @xyleth. Is there anyway that you can repeat the import from USB process and capture the content of the log? Alternatively if you wanted to send the old SD card to us we can try to work out why it isnt importing correctly here and hopefully be able to give you a new card with a restored copy of the data, feel free to email us on [email protected] and we can get this sorted for you. We’d also be happy to refund the new SD card given that this did not work for you.

1 Like