Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Emoncms emonSD-13Jun18 Login fail

Tags: #<Tag:0x00007f1bd8222e50>

Hello to everyone!

I am an engineer at the german railway. The person before me had bought a Raspberry Pie 3B + to record current and voltage on the train and installed on it http://files.openenergymonitor.org/emonSD-13Jun18.img.zip. Now it is not clear to me how I can access the OpenEnergy website and which login data the person chose. I can log into the Raspberry. Is there any way to get ahead here?

Thank you very much for any help!

Welcome, Uli, to the OEM forum.

This might help you:

I think that post will refer to the same version that you have. If not. it should help but the details might not be absolutely correct.

If the existing data is valuable, it might be a good idea to image the whole SD card first, so that you have the data if anything goes wrong.

This is the output I get.

And if I type in “$ php /opt/emoncms/modules/usefulscripts/resetpassword.php” from https://guide.openenergymonitor.org/setup/troubleshooting/#emoncms-local-password-reset I get " Could not open input file"

Hello @UliDB I cant quite work out what you are doing in those screenshots. Have you tried using puTTY for SSH access via windows? https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html

The default SSH password is emonpi2016.

On the image that you have I think the reset password script can be found here:

php /home/pi/usefulscripts/resetpassword.php

First of all I want to thank you for the quick answers!
The command worked and I was able to reset my password. Now I am still missing the username. If I enter the command for the username (see picture), then access is denied.

Ah the mysql username should be emoncms and password emonpiemoncmsmysql2016

You could then find the emoncms username with the following:

SELECT * FROM users;

That will just list all users

" Ah the mysql username should be emoncms and password emonpiemoncmsmysql2016" did not work unfortunately…

and I typed in “SELECT * FROM users;” earlier. You can see this in my 3rd and 4th message of this conversation. In addition to that, i uploaded the latest SSH commands, right under this message. It seems like the MySQL doesn´t give me permission to enter the settings.

I could change the password, due to your message before. Apparently the login data is something default, mentioned a colleague of mine.

Thank you very much for your help!!