Emoncms Android App Feed List

Hello guys,

I have a Emoncms (9.7.7) instance installed and I’m trying to use the Android app, I can connect to the server but there are no feeds listed int the app, attached are some print screens from the Emoncms and Android app. Do you know what I’m doing wrong?

Thanks and congrats on a great platform,


Please attach your image to your post as opposed to putting it on a third party site.

If, for some reason the image becomes inaccessible, your post loses it’s value.

I’ve increased your privileges so you should be able to do that now.


Thanks, I’ve uploaded the pictures here, I wasn’t able to do that before, that is why I ended up using imgur.

Hi Mihai, in the settings screen in the app you need to select the two feeds to display - [edit I just re-read your original post, and it says “there are no feeds listed in the app”. If that’s true, then I think the most of my post is irrelevant… so skip to the end]

… currently it is set to “Auto”. I believe Auto looks for feeds with ‘standard’ names (which I think you could find if you search in this forum). However I assume you are not using those standard feed names, which is why it isn’t working, so you need to manually specify the feed names.

From looking at your list of feeds, I think you want to use your feeds called “Instant power” and “kWH”. So in the App settings screen, tap “power feed (Watts)”, and a list of your available feeds should appear. Select the one called Instant Power. Then tap the next field, called “Bar graph feed (kwh)”, select you feed called kwh, and then press the back button and hopefully the graphs will appear.

Are you storing data on a local server, or on emoncms.org? and which server is the App connecting to?

Hello Ian, first of all thank you for your answer.
Yes I do not have any feeds listed in the drop down menu, the only option is AUTO SELECT.
I’m hosting my own instance of emoncms on my local server.
Since I’ve posted I’ve tried the following:

  1. Upgraded to 9.8.10
  2. Installed the apps Module where I get the same behavior (no feeds listed) - Screenshot below
  3. If I try to get the feed list form the API it works - Screenshot below
  4. I’ve tried eliminating the “:” from the names of the feeds, thinking the maybe it breaks the json parsing
    Nothing worked …


Hi Mihai, have you configured the app to connect to your emoncms URL and provided the read API key for your emoncms? This is in the App settings, in the Accounts section.

Yes I did configure the app, and it does connect (tried http and https), I can see it in the apache logs.
" - - [07/Sep/2017:09:28:20 +0300] “GET /emoncms/feed/list.json?apikey=<removed> HTTP/1.1” 200 4126"

As far as I know, the APP doesn’t support MySQL-feeds. Try to add a feed with the PHPFINA engine…

This is actually the correct answer, it works with PHPfina. Not sure why this isn’t stated more clearly…

1 Like