Community
OpenEnergyMonitor

OpenEnergyMonitor Community

EmonBase + EmonTx - Can't get any readings

Hi,

I got a used EmonTx and RFM69Pi V3 paired with a Raspberry Pi 1 a very long time ago. I have a project I could use this for, so I stuck the RFM69Pi V3 on a Pi3 and installed the latest stable image

I can get to everything, but I can’t seem to get any readings

I followed the Raspberry Pi 3 Compatibility steps, however in “Imputs” I see nothing. Is this where I should be looking?

I don’t have the CT’s on anything, but I do have the temp sensor connected

In the EmonHub log, I see this. Does this mean its connected?

2021-07-05 17:45:30,035 DEBUG RFM2Pi acknowledged command: i - set node ID (standard node ids are 1…30)
2021-07-05 17:45:30,138 DEBUG RFM2Pi acknowledged command: b - set MHz band (4 = 433, 8 = 868, 9 = 915)
2021-07-05 17:45:30,242 DEBUG RFM2Pi acknowledged command: o - change frequency offset within the band (default 1600)
2021-07-05 17:45:30,451 DEBUG RFM2Pi acknowledged command: g - set network group (RFM12 only allows 212, 0 = any)
2021-07-05 17:45:30,554 DEBUG RFM2Pi acknowledged command: c - set collect mode (advanced, normally 0)
2021-07-05 17:45:30,770 DEBUG RFM2Pi acknowledged command: …, a - send data packet to node , request ack
2021-07-05 17:45:30,873 DEBUG RFM2Pi acknowledged command: …, s - send data packet to node , no ack
2021-07-05 17:45:30,976 DEBUG RFM2Pi acknowledged command: q - set quiet mode (1 = don’t report bad packets)
2021-07-05 17:45:31,081 DEBUG RFM2Pi acknowledged command: x - set reporting format (0: decimal, 1: hex, 2: hex+ascii)
2021-07-05 17:45:31,393 DEBUG RFM2Pi acknowledged command: ,,, f - FS20 command (868 MHz)
2021-07-05 17:45:31,498 DEBUG RFM2Pi acknowledged command: ,, k - KAKU command (433 MHz)
2021-07-05 17:45:31,703 DEBUG RFM2Pi device settings updated: E i5 g210 @ 433 MHz q1

If I enter

sudo minicom -D /dev/ttyAMA0 -b38400

I get some kind of readings it looks like?

Current configuration:
E i5 g210 @ 433 MHz q1
OK 9 0 0 0 0 0 0 0 0 152 48 12 1 (-84)
OK 9 0 0 0 0 0 0 0 0 127 48 12 1 (-86)
OK 9 0 0 0 0 0 0 0 0 111 48 12 1 (-85)
OK 9 0 0 0 0 0 0 0 0 101 48 12 1 (-83)
OK 9 0 0 0 0 0 0 0 0 119 48 12 1 (-84)

However, the inputs all show empty still

Any clue what I am doing wrong? It seems like I’m so close!

Okay I updated the firmware of the RFM69Pi, worked fine. And when I power on the TempnTx they both flash

When the EmonTX flashes, so does the RFM69Pi. So the data is getting there. It just seems like there is a disconnect in the software somewhere

Welcome, Jim, to the OEM forum.

OK, that second post confirms that the emonTx is transmitting and the RFM69Pi is receiving. You are indeed close.

Over time, the baud rate that the RFM69Pi (or the RFM12Pi before it) uses has changed, so you might be listening at the wrong speed (I can’t see the relevant line in the bit you copied). In emonCMS, in Setup and emonHub, try looking at the log. If there’s no activity, it could well be the baud rate. In emonhub.conf, [Edit config] the line is

        com_baud = 38400                        # 9600 for old RFM12Pi

and if everything is new, that value of 38400 should be correct. If it isn’t, various speeds (9600 as mentioned) have been used, so don’t be afraid to try them all. (No need to reboot each time, the file is read as soon as a change is saved and seen.)
If you’re seeing activity there, it’s probably a case that the Node definition for your emonTx is wrong, and for that you need to know what the emonTx is actually sending, i.e. which sketch is loaded into it.

OK 9 0 0 0 0 0 0 0 0 152 48 12 1 (-84)

Decoding that, 9 is the Node ID, then it sends 12 bytes, and (-84) is the received signal strength added by the RFM69Pi.
Now I’m a bit stumped, because the only “standard” sketch for the emonTx that fits that is emonTxFirmware/emonTxV3/unsorted_examples/EmonTxV3HeatpumpMonitor/EmonTxV3HeatpumpMonitor.ino
If the definition lower down the emonhub.conf file for Node 9 doesn’t match the data being sent - which it doesn’t, the message is rejected - and you should see that happening in the log window.
Because it looks like a non-standard sketch, I can’t really tell you what you need to have to decode the numbers. Usually, sketches send signed or unsigned integers, as you have a temperature sensor connected, my guess is the last two bytes are 26.8 °C (12 + 1×256 = 268). What the others are, I don’t know, but it’s likely that the first four pairs are powers.

If you have a programmer, I suggest you connect that and use the Arduino IDE to read a message printed to the serial port of the emonTx immediately after it powers up. It should identify itself.

It looks to me as if you might want to load a modern sketch into the emonTx, then you’ll have full details of what you have and what it does.

Okay so at least I’m not going crazy. When I got this thing I was using a 2018 build of Emoncms I still have the IMG file for, and just worked out of the box

Perhaps I should flash that and confirm it still worked as it should, just to rule out anything funny happening

Perhaps I missed in in the docs, but how do I change the sketch?

You need a programmer and the Arduino IDE on a computer. You can get a multitude of sketches from Github, the present default is this: GitHub - openenergymonitor/EmonTxV3CM: EmonTxV3 Continuous Monitoring Firmware (Default shipped EmonTxV3 firmware) (that’s if your emonTx is a V3.4 - if it isn’t, I’ll sort out a sketch for you).
The full instructions for setting up and using the Arduino IDE are in ‘Learn’. I cannot recommend the alternative platformio - when I tried it, it destroyed my OEM system.

I’ve looked at a 2016 and a 2019 emonhub.conf, and neither has a Node 9 that fits the data you’re receiving. So the previous owner has customised it to suit the sketch in the emonTx.

I cannot advise staying with that 2018 version. I’m fairly certain that even if it’s still possible to upgrade from that, it won’t stay like that for long. I suggest keeping the latest version of emonCMS, because from what you’ve written, the problem is only that you have a sketch but you don’t know what it is or what it does. If you still had the emonhub.conf file that “worked”, then you would simply copy the entry for Node 9 from that into your present emonhub.conf, and I’m reasonably certain that it would again ‘just work’. But you lost that when you flashed the SD card with the emonCMS version you have now.