Community
OpenEnergyMonitor

Community

Emonbase connected to emonTx - very large readings & no WiFi connection

Tags: #<Tag:0x00007f56b7b0b4d0>

Hi,

I’ve tried setting up my emonbase for the 1st time. It works via an ethernet cable to the router but can’t connect to the WIFI. I’m trying to connect in Emoncms. It locates the WIFI router, I get the message ‘config saved’ but clicking refresh does nothing and the Emonbase remains disconnected. I’ve tried cycling the router a few times with no success.

The second issue is that the numbers coming through from the EmonTX (running on batteries) are massive. Does it require calibration?

Any advice would be appreciated!

Welcome, Rhodri to the OEM forum.

I can’t help you with the WiFi problem - you need an emonCMS expert for that.

Your emonTx - which sketch and library is it using? Did you specifically order it for battery operation?

If you’re running on batteries, you need the older sketch and the old emonLib, which samples the currents for 300 ms every 10 s (and goes to sleep in between, thus saving battery power). If you ordered it for battery operation, the shop has slipped up so email them, mentioning this thread. Your screenshot indicates you might be using the newer sketch that uses the continuous monitoring (“CM”) library, which not only will use batteries faster, it also XORs each data byte with 0x55 to avoid sending long streams of ‘0’ bits over the radio, which the receiver in your emonBase can struggle with. It seems highly likely that the version of emonHub that you have doesn’t do the XOR operation to reverse the process.
(Try adding “whitening = 1” to the Node15 definition in emonhub.conf:

[[15]]
    nodename = emontx3cm15
    [[[rx]]]
       names = MSG, Vrms, P1, P2, P3, P4, E1, E2, E3, E4, T1, T2, T3, pulse
       datacodes = L,h,h,h,h,h,L,L,L,L,h,h,h,L  
       scales = 1,0.01,1,1,1,1,1,1,1,1,0.01,0.01,0.01,1
       units = n,V,W,W,W,W,Wh,Wh,Wh,Wh,C,C,C,p
       whitening = 1

If your emonHub is capable, that should restore sensible numbers - but only with the “CM” sketch - the discrete sample sketch doesn’t do “data whitening”.)

If you’re staying with battery operation, I think you need a programmer to reload the sketch in your emonTx. The one you want is here: https://github.com/openenergymonitor/emontx3/tree/master/firmware
(If you don’t have the Arduino IDE to compile and load it, all you need to know is here: Learn→Electricity Monitoring→Using the Arduino IDE

First question, is it an EmonBase or an EmonPi? https://shop.openenergymonitor.com/base-stations/

It’s an emonbase. It couldn’t detect my router on initial setup, so I connected it via Ethernet. It then did detect it in Emoncms but won’t connect?

Ah, ok. It will be plugged in in it’s intended location. I was just familiarising myself with the system. Thanks!

So, it looks as if the emonCMS you downloaded (? - or bought on the SD card) needs updating to include the latest emonHub (which is part of the integrated system).

[Edit]
Can you copy and attach the definition of Node 15 in your emonhub.conf file. It should look like the one in post no.2 above - I suspect it doesn’t. Looking again at the numbers from your screenshot, I don’t think “whitening” is the problem.

Great, thanks.

Which model Pi are you using? Did you get an SD card from the shop, or flash one yourself?

Can you click on the button Copy as Markdown next to Server Information on the Admin page and paste here please (no further formatting required).