Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Emon ESP not broadcasting network

Tags: #<Tag:0x00007fc9bcee57e0>

Hi All,

I have recivied an ESP to connect to my EmonTX. I plugged it in and powered the EmonTX via USB (removing the jumper), but i did not see the wifi network being broadcast.

I have tried to reflash the ESP with the latest firmware (after manually downloading and unzipping ESPAsyncTCP and ESPAsyncWebServer to the Libraries folder) and when it boots i am getting

EmonESP 1717510
Firmware: BUILD_TAG

Exception (3):
epc1=0x401003e9 epc2=0x00000000 epc3=0x00000000 excvaddr=0x4004a901 depc=0x00000000

ctx: cont
sp: 3fff1d40 end: 3fff20d0 offset: 01a0

stack>>>
3fff1ee0: feefeffe feefeffe feefeffe feefeffe
3fff1ef0: feefeffe feefeffe feefeffe 3fff2010
3fff1f00: 00000498 00000498 000003fe 401004f4
3fff1f10: 40004b31 00001000 000003fe 4010689c
3fff1f20: 40105710 feefeffe feefeffe 4024f20d
3fff1f30: 401063dd 4024f2f7 3fff38cc 00000498
3fff1f40: 000003fd 3fff2010 3fff38cc 4024f2da
3fff1f50: ffffff01 55aa55aa 00000001 00000020
3fff1f60: 0000001c 000000ec 00000084 aa55aa55
3fff1f70: 000003ff 4024f7a7 3fff38cc 3fff38cc
3fff1f80: 000000ff feefeffe feefeffe feefeffe
3fff1f90: 00000001 3fff38dc 4024f9a7 00000008
3fff1fa0: 3fff38cc 000000ff 3fff2010 3fff2030
3fff1fb0: 3fff3903 55aa55aa 00000001 00000020
3fff1fc0: 3fff398c 3fff2071 00000001 4024fa56
3fff1fd0: 3fff2010 4025e3e0 3fffdad0 3fff10a8
3fff1fe0: 3fff2030 3fff9c04 3fff2010 4024fa25
3fff1ff0: 3fff38cc 4024fa8c 3fff0fe8 00000000
3fff2000: 4021068c 000001bd 000001bd 4010020c
3fff2010: 00000000 000001bd 3fff36c4 40100648
3fff2020: 00000014 00000dc0 000001b8 000001b8
3fff2030: 00000000 400042db 3ffe99c1 4021a804
3fff2040: 40004b31 3fff36c4 00000200 003fb000
3fff2050: 40105710 00000200 3fff0cd4 401004d8
3fff2060: 00000010 3fff36c4 00000200 3fffdad0
3fff2070: 3fffdad0 00000000 3fff0cd4 3fff10a8
3fff2080: 3fffdad0 3fff0c88 3fff0fe8 40209ada
3fff2090: 3fffdad0 00000000 3fff0fe8 40207fda
3fff20a0: 00000000 00000000 00000000 feefeffe
3fff20b0: feefeffe feefeffe 3fff10a1 40218cd4
3fff20c0: feefeffe feefeffe 3fff10b0 4010070c
<<<stack<<<

ets Jan 8 2013,rst cause:2, boot mode:(3,0)

load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d
v0c897c37
~ld

Thanks
Paul

Hi

I had a similar problem. I solved it by using platform io to update firmware (and spiffs, did you upload that to your esp?)

See here towards the bottom of the page:-

I have been struggling with this all day, Here is a list of commands i ran to get it working. in linux i used a raspberry pi

sudo apt-get install python-pip

sudo pip install esptool

git clone https://github.com/openenergymonitor/EmonESP

cd EmonESP

wget https://github.com/openenergymonitor/EmonESP/releases/download/2.2.3/firmware.bin

wget https://github.com/openenergymonitor/EmonESP/releases/download/2.2.3/spiffs.bin

Put ESP8266 in bootloader mode by holding gpio0 button while pluging it in.

esptool.py erase_flash

esptool.py write_flash 0x000000 blank_1MB.bin 0x100000 blank_1MB.bin 0x200000 blank_1MB.bin 0x300000 blank_1MB.bin

reboot the ESP8266 and put back into bootloader mode

esptool.py write_flash 0x000000 firmware.bin 0x300000 spiffs.bin

reboot the ESP8266 and you should see the wireless network