Email Reset Undefined Error

Hi All,

I have a local version of EmonCMS installed at My Solar - user login
When trying to reset a password an error comes up under the “Recover” button with “undefined” as the error message.

Originally I was getting email sent message. But in log it said can’t find SwiftMailer and the email was not sent.

To fix this:
I downloaded Swiftmailer, unzipped it and dragged it first inside the emoncms Lib folder, then tried in the root directory. I changed the directories in the Lib/email.php file

    $this->message = null;
    // include SwiftMailer. path from a PEAR install,
    $this->have_swift = @include_once ("../swiftmailer/lib/swift_required.php");
    // path from module lib
    if (!$this->have_swift) {
       $this->have_swift = @include_once ("../swiftmailer/lib/swift_required.php");

Now no error is showing up in the log. But I am getting the Undefined set above and no email has been sent.

I have tried using multiple email accounts in the settings.php file including a gmail smtp outgoing server.

$smtp_email_settings = array(
  'port'=>"465",  // 25, 465, 587
  'from'=>array('[email protected]' => 'Anamise'),
  // comment lines below that dont apply
  'encryption'=>"ssl", // ssl, tls
  'username'=>"[email protected]",

Does anyone have any suggestions or instructions on how to fix this?

I’m not extra sure but seems with their latest round of security measures from gmail you have to set ‘allow less secure apps to access your gmail account’

try this page to set it and test

Thanks Eric, access for less secure apps is turned on. Still no luck.

Because I am on shared cloud hosting I am not sure if I installed swiftmailer correctly. All I did was download the github file, unzip it and drag it onto the webserver using ftp app filezilla. Is there anything else I need to do to install or setup swiftmailer properly?

I have tried connecting using tls and port 587 as well but no luck.

Check the path to Swiftmailer (search - it’s been mentioned before).