Edit Dashboard

Some of my dashboards are broken. when i try to edit them you cannot click on an item but you can find them in a box bottom right of the screen


I cannot create any dashboards now, I have sat here for the last 2 hours creating a new layout and saving it as i go along, i left the dashboard and then went back in.

is they any debuging that can done?

You maybe added a widget which was not configured before you saved the dashboard.

If you are using Chrome you can use F12, then click on “console”. If you see a message like “Review config for feed id of bar” or whatever widget you maybe added, then you know you have one that is not configured.
Some not configured widgets can prevent the dashboard from loading fully.

I have done a clean install this morning and resetup all of the feeds. same problem.

if i look at the console like @Andreas_Messerli post

jquery-1.11.3.min.js:5 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check https://xhr.spec.whatwg.org/.
send @ jquery-1.11.3.min.js:5

@glyn.hudson can you help with this, as none of the dashboards are working for me, even on a clean install.


The depreciation message is nothing to be concerned about, but maybe a long shot… after installing the dashboard module, did you update your database?

Setup > Administration > Update database


Hi Paul

Sure did and it makes no difference


Paul, if I get chance tonight, I’m building a Jessie system from scratch, so I’ll see if I get the same result.

I assume you are using Jessie?

I’ve built 2 systems using ‘stretch’ over the past week, and the dashboards worked fine on those…


Hi Paul,

Yes i am using Jessie.

If you would like I could give you remote access to have a look, or i could send over a backup file.


  1. Starting from scratch, with a brand new ‘Jessie’ OS image from here, written to a new 8GB sd card.
  2. Installed emoncms by using the steps explained here
  3. Installed ‘dashboard’ as explained here
  4. Add some data via api & create feeds
  5. Create 2 dashboards as shown below

Everything worked fine, dashboards created and saved OK.


Hi Paul,

I added about 10 dials and a battery, some white boxes and text. it would look ok on the edit screen and save ok. It was when you went back in to edit they the error would appear.