OpenEnergyMonitor Community

Eco charging not fully using solar surplus

I was hoping someone might be able to help me figure out why my OpenEVSE is not maximising my solar surplus in ECO mode, and help me fix it.
It’s under utilizing by around -400W ) My car is a Nissan Leaf.

I’ve always had this problem (Bought evse in 2016), so I though maybe upgrading everything to the latest software might fix it, but alas it is just the same. (now on emonSD-24Jul20 / OpenEVSE Wifi 2.9.1 / OpenEVSE 7.1.3 )

Weirdly, it is no longer displaying the OpenEVSE firmware and protocol values in the web interface, even though it’s communicating with it just fine (not sure if that’s a clue). I’m sure it displayed it before I updated all the softwares.


Is there some setting I can change or adjustment I can make to calibrate it to give me that extra bit of free power?

Here are some of my settings:

By default the EVSE has a 100W reserve, i.e the solar PV divert should be about 100W less than the available surplus. This can be adjusted by changing the PV divert ratio, set the ratio to 1 to divert all the excess power, or less than 1 to divert more than excess i.e import a little bit

The fact that you can see a difference greater than 100W is probably due to measurment error between the EVSE and emonPi

Thanks Glyn. Unfortunately, that option seems to be missing for me.
Would that have anything to do with my having a Huzzah ESP8266. Do I need to upgrade to ESP32?

Ah yes good point, this feature is only available in V3 onwards which requires the ESP32 OpenEVSE WiFi module

Ok, Thanks Glyn. I will get it upgraded.

If you do choose to order a ESP32 module via the shop, please make a note that you have a V5 controller which requires a different communication cable than the new V5.5. We will be sure to include the correct cable.