Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Download EmonSD failures

Has anyone tried to download an Emoncms image recently? I have been trying, and have used 2 Mac laptops and both Safari and Firefox (from Melbourne, Aus). The downloads fail at the same point - 1.08GB - in all cases, from URL: emonSD pre built SD card Download & Change Log · openenergymonitor/emonpi Wiki · GitHub.
Tried both 8May21 and 24Jul20 downloads. Advice welcome!
Safari gives the error:

Something similar happened when I tried to download said file.

~12 minutes into the transfer, it aborted for no apparent reason. I didn’t get any error msgs.

I resumed the transfer (via Firefox) and after 5 more minutes, the transfer was complete.
An archive integrity check yielded no errors.


Have you tried resuming the transfer vice restarting it?
i.e. clicking on the orange spot with the clockwise arrow in it.

Hi Bill - thanks for the reply. Yes, tried resuming, the download starts again from scratch (as opposed to start from the end of the failed download). Tried again this morning (15hrs later) with both Safari and Firefox with identical result - fails at 1.08GB. Will try again later, and will download and install Chrome to see if it makes any difference.


Me too, in the UK using Opera Version:71.0.3770.271 on Ubuntu 20.04.2 LTS

It stopped at around the same place: 1.1 GB of 1.6 GB, with “Network error”. It continued with a Resume.
Likewise, the MD5 hash agreed with the published value.

Thanks for the support - its great to know others have had the same issue.
Meanwhile - Success. Used Firefox on a Mac Air running Big Sur; after it failed I was able to restart the download and it picked up from the 1.0bGB failed point.
Sad to say the fresh download has not solved my issue, so I will start another topic to see if I can get further advice.