Does this even work on a Raspberry Zero !?

I doubt it’s that the latest image download supports 16GB, did you download the updated version?

Question is why did mine boot up fine a minute ago but is not doing so now… I’ve got a couple of the display adapters on order so that I can check the terminal output

1 Like

Must be. It was Etcher that was complaining before.

Mine looks exactly the same - on the underside it says Pi Zero W V1.1 and copyright 2017.


1 Like

We’ve also got 5 of the latest pi zero’s coming from raspberrypi for testing sometime in the next few weeks. So that should help.

1 Like

I was hoping to get a 2W sometime in the near future but I’m guessing it will be Q2 as they’ve said supply issues should be sorted by then.

Just as an update, I ran the emonscript last night, after 90 minutes, the apt upgrade was still running, I went to bed. This morning it had stopped at a reboot message. I set it off again, but left the house. I’ll check back tonight.

I’m reasonably sure the emonSD still does an apt update on first boot (I could be wrong).

Summary, boot it up, leave it overnight :wink:

If I understand correctly the latest are 64 bit where the original is a 32 bit

I have completed the manual install and it is ‘running’ at the moment I am just trying to get the mod rewrite working so that I can get past the register user for login

I own a Raspberry Pi Model Zero W Rev 1.1 - 512MB (Sony UK), it runs smoothly on it, it has always been. I’ve installed it with emonSD-21Jul21, updated to 11.3.0. I periodically update the main system with apt get-update and upgrade, for security reasons, along the emoncms

there is no way for a 64bit system to run on Rpi0: 64bit runs only on Rpi02

My comment about the 64 bit is that the new Rpi0 W2 is a 64 bit system not 32

1 Like

I got it sort of running using the manual build but with errors like there are no log files etc. Perhaps I will try an old SD image like the one that ivancaregnato used and see if I get better results

@borpin How were you connected - dial up? :wink:

If you do the update and upgrade after you’ve prepped the SD card, it doesn’t take anywhere near that long.

Or maybe you are on an even older Zero, or a slow SD card?


Hopefully David, @borpin and @TrystanLea will be able to sort out the issues with the scripts and we’ll soon be sorted.

I’ve run though the steps to create the extra partition that @borpin posted last night and these seem to work ok. So just the scripts to fix.


Yes a 1.3 non W

It is the same process. Updating the firmware takes quite a long time.

In answer to the OP - No!

I’ve got as far as installing emoncms, but then hit multiple problems @TrystanLea

The latest version of Bullseye has a number of changes to different packages that breaks things in all sorts of places. If an exisiting system is apt upgrade it will break :frowning:

Lots of the things have been pushed to master repos, but not all. I also made the mistake of not pulling in the master EmonScripts branch :frowning:

Latest issue is that during install, we break a working Wi-Fi setup as created by the RPi Imager. Not fixed that yet.

Summary (not all specific to the PiZ)

  • PHP 8.1 is broken for the PiZ 1.3 - works with PHP8.0
  • Takes forever on an old PiZ to install
  • Logrotate broken - needs testing to check permissions - it is more picky than it used to be.
  • emonhub log not created. Probably should be added to the service as an ExStartPre directive
  • demandshaper is a cpu hog
  • emonPiLCD was accidentally installed
  • permissions on log files incorrect, but that might have been fixed with the master EmonScripts branch.
  • log2Ram config file 00_olddir is broken, needs and extra line at end (PR in repo)
  • latest git breaks the components page (PR in repo)
  • journald writing files to /var/log (as you know)

I think we should drop support for the PiZero for the EmonSD, but adjust scripts so it can be installed manually and provide some advice on how to do it. It might also affect the Pi2 as well.

It takes an ^&*ing long time to install (PiZ 1.3), so testing setups takes hours of waiting :frowning:

1 Like

@TrystanLea completely stuck as I cannot work out why the Wi-Fi setup will not work. It worked out of the box, but the install scripts have done something to muck it up.

1 Like

Brian, did you say your PiZ was not a W, so has a WiFi dongle? If so could this be the causing you problems?

I have a 1.3 W so can try to do the install, although I’ve bricked an SD card with all the different combinations of things I’ve tried!! It would be great if someone who has a PiZ 2W could give things a try, as someone said on another thread, these are newer CPUs, so things should work?

Let me know if I can test anything for you. Point me to the right location to download any revised scripts.


Possibly (yes a 1.3 without Wi-Fi but with a dongle), it worked out of the box with the OS flash, but the install scripts have screwed it up and I don’t know what they do exactly so cannot work out what the issue is. The hostapd and dhcp srvers will not start on reboot after install.

If you look at the master Branch. My partial mistake was not pulling this branch in - just pulled stable in :frowning:

1 Like