Disable RFM on EmonTX

Hi All,

I have installed an EmonESP to a EmonTX v3, i would like to disable the 433Mhz from broadcasting is it just a case of changing a line in the firmware to “boolean RF_STATUS = 0”

//-----------------------RFM12B / RFM69CW SETTINGS----------------------------------------------------------------------------------------------------
byte RF_freq=RF12_433MHZ;                                           // Frequency of RF69CW module can be RF12_433MHZ, RF12_868MHZ or RF12_915MHZ. You should use the one matching the module you have.
byte nodeID = 8;                                                    // emonTx RFM12B node ID
int networkGroup = 210;
boolean RF_STATUS = 1;                                              // Enable RF

Yes - that should disable it completely.

Hi Robert,

Thanks for the information.

If it doesn’t, or for anyone not using the latest sketch, comment out the lines (or block) that contain one or more of these:

rf12_initialize( ...
rf12_sendNow( ...
rf12_sendWait( ...