Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Device Error, I cannot edit inputs. Bit of a show stopper HELP!

Hi

As I describe in another post I have problems following adding OpenEVSE.

However the most immediate problem relates to devices. How do I delete the problem device. I have tried every thing I can think of.

I get this on the input screen continually so I cannot work on inputs at all.

deviceerror

HELP!!

This error crops up quite often (not related to EVESE). Unfortunately, as yet, @TrystanLea, @Gwil et al have not been able to replicate it.

Fully refresh page to clear cache may help. It doesn’t usually affect the actual working.

Thanks Brian.

Tried accessing inputs on 3 different PCs a phone and an Ipad. All have the same error. With the Ipad I can suppress dialogues to gain access to inputs but it is not easy on a touch screen to carry out editing.

There must be away behind the scenes so to speak to delete devices maybe at a file level. I have SSH and WinSCP access.

I could create a fresh SD card and import data but my concern is that the duff data will just copy across.

I just confirmed clearing cache does not help, problem still there.

@Gwil I did suggest a solution on GitHub.

@ian Have you tried rebooting the emonPi (or whatever device emoncms is on)?

Clearing redis will clear the error, either from the admin page or from the command line. This isn’t entirely without risk as it may effect redis dependent feeds or processes. The best course of action is to delete all “device” prefixed redis entries. I cannot recall the command offhand now, will try and find it later if I remember.

@ian, can you try this please,

http://IP_ADDRESS/device/list.json

and post the output.

I found Trystans post about clearing redis.
Tried it several times to no avail.
(Unless I am doing it wrong, but I always get OK as a response)

Command used redis-cli flushall

1 Like
[{"id":"374","userid":"1","nodeid":"15","name":"15","description":"","type":"","devicekey":"","time":false},{"id":"16","userid":"1","nodeid":"17","name":"17","description":"","type":"","devicekey":"","time":false},{"id":"19","userid":"1","nodeid":"18","name":"18","description":"","type":"","devicekey":"","time":false},{"id":"18","userid":"1","nodeid":"20","name":"20","description":"","type":"","devicekey":"","time":false},{"id":"8","userid":"1","nodeid":"23","name":"23","description":"","type":"","devicekey":"","time":false},{"id":"17","userid":"1","nodeid":"28","name":"28","description":"","type":"","devicekey":"","time":false},{"id":"373","userid":"1","nodeid":"5","name":"5","description":"","type":"","devicekey":"","time":false},{"id":"28","userid":"1","nodeid":"8","name":"8","description":"Back Shed","type":"","devicekey":"","time":false},{"id":"3","userid":"1","nodeid":"BShed","name":"BShed","description":"","type":"","devicekey":"","time":false},{"id":"4","userid":"1","nodeid":"BShedH","name":"BShedH","description":"","type":"","devicekey":"","time":false},{"id":"371","userid":"1","nodeid":"Elec00-00","name":"Elec00-00","description":"","type":"","devicekey":"","time":false},{"id":"257","userid":"1","nodeid":"GRoom","name":"GRoom","description":"","type":"","devicekey":"","time":false},{"id":"260","userid":"1","nodeid":"GRoomH","name":"GRoomH","description":"","type":"","devicekey":"","time":false},{"id":"31","userid":"1","nodeid":"GardenRoom","name":"GardenRoom","description":"","type":"","devicekey":"","time":false},{"id":"372","userid":"1","nodeid":"Gas00-00","name":"Gas00-00","description":"","type":"","devicekey":"","time":false},{"id":"319","userid":"1","nodeid":"Hild","name":"Hild","description":"","type":"","devicekey":"","time":false},{"id":"318","userid":"1","nodeid":"Lux","name":"Lux","description":"","type":"","devicekey":"","time":false},{"id":"341","userid":"1","nodeid":"LuxCT","name":"LuxCT","description":"","type":"","devicekey":"","time":false},{"id":"258","userid":"1","nodeid":"Office","name":"Office","description":"","type":"","devicekey":"","time":false},{"id":"259","userid":"1","nodeid":"OfficeH","name":"OfficeH","description":"","type":"","devicekey":"","time":false},{"id":"370","userid":"1","nodeid":"OpenEVSE","name":"OpenEVSE","description":"","type":"openevse","devicekey":"c584773df389ee5d70bdfa2fbdd3b3d0","time":false},{"id":"27","userid":"1","nodeid":"OtempESP","name":"OtempESP","description":"","type":"","devicekey":"","time":false},{"id":"24","userid":"1","nodeid":"OtempF","name":"OtempF","description":"","type":"","devicekey":"","time":false},{"id":"1","userid":"1","nodeid":"Power","name":"Power","description":"","type":"","devicekey":"","time":false},{"id":"9","userid":"1","nodeid":"RainGauge","name":"RainGauge","description":"","type":"","devicekey":"","time":false},{"id":"358","userid":"1","nodeid":"ShedFreezer","name":"ShedFreezer","description":"","type":"","devicekey":"","time":false},{"id":"5","userid":"1","nodeid":"WShed","name":"WShed","description":"","type":"","devicekey":"","time":false},{"id":"6","userid":"1","nodeid":"WShedH","name":"WShedH","description":"","type":"","devicekey":"","time":false},{"id":"77","userid":"1","nodeid":"WoodShed","name":"WoodShed","description":"","type":"","devicekey":"","time":false},{"id":"30","userid":"1","nodeid":"cottage","name":"cottage","description":"","type":"","devicekey":"","time":false},{"id":"25","userid":"1","nodeid":"heartbeat","name":"heartbeat","description":"","type":"","devicekey":"","time":false},{"id":"343","userid":"1","nodeid":"smart","name":"smart","description":"","type":"","devicekey":"","time":false},{"id":"321","userid":"1","nodeid":"smartplug2086","name":"smartplug2086:smartplug","description":"","type":"smartplug","devicekey":"","time":false},{"id":"322","userid":"1","nodeid":"smartplugTD","name":"smartplugTD:smartplug","description":"","type":"smartplug","devicekey":"","time":false}]

MOD - I pulled out just the device we are interested in - Brian

{
	"id": "370",
	"userid": "1",
	"nodeid": "OpenEVSE",
	"name": "OpenEVSE",
	"description": "",
	"type": "openevse",
	"devicekey": "c584773df389ee5d70bdfa2fbdd3b3d0",
	"time": false
}

Can you link so I can see if we’re on the same page?

Can you check the emoncms logs (you may need to set as debug in the settings.ini) and see what emoncms is receiving as the input.

Possible solution - I am not sure where you specify the nodeid in the OpenEVSE system, but I’d try and change it to something different (make it all lower case for instance).

The next bit comes with no warranty at all and could really muck things up - I don’t know the effect but

http://IP_ADDRESS/device/delete.json?nodeid=OpenEVSE

MAY work…

Curious

I named Node OpenEVSE as per instructions:

The odd thing is it appears in inputs as openevse (lower case)
The MQTT base topic is also openevse (lower case )

So all the data appears in inputs under openevse. I keep trying to get a screen shot of the inputs but the device error makes it difficult!

I tried
http://192.168.1.22/device/delete.json?nodeid=openevse
and
http://192.168.1.22/device/delete.json?nodeid=OpenEVSE

Both returned:-

{“success”:false,“message”:“Device does not exist”}

Is it still listed in a call to device/list.json?

Having tried to delete in the other thread, it might be worth trying to flush redis again.
Is emoncms otherwise up to date?

Do you recall the command for just deleting device prefixes rather than all redis so as not to upset any processes (eg whaccumulator).

Emoncms is up to date but not on latest image

Is it worth starting with latest image in the morning and pulling data in from current SD?

Just tried deleting from device list view followed by:-

[email protected]:~ $ redis-cli flushall
OK
[email protected]:~ $

Still appears on list.

Time for tea today, Try and pick this up in the morning.

Just noticed it is after the id as the parameter so that would be 370 I think.

Thanks @ian trying to remind myself of the code internals here that are causing this. I thought we had it sorted.

If the error appears, it should mean that the device should not exist in ‘device/list.json’

There is a difference in capitalisation between the ‘OpenEVSE’ device in the device list result you posted above and the error message that may be indicating something.

There was a commit to the device module last February that was meant to fix this issue https://github.com/emoncms/device/commit/d5b0a565d339547ca8a2bc346c4cc0f50aef9870 did you update via the Admin > Update UI? Could you perhaps post an update log? might be worth checking that there is nothing blocking the update on that module.

That might be worth doing, do you know which image version you are running at the moment?

I noticed that. Also note though the ‘type’ is LC.

The code is at

I get it on a numerical node sometimes! I think the inputs array does not always load correctly. Could it be down to number of inputs? If a large number, could the ajax call not complete properly?