DemandShaper/OpenEVSE/ Unresponsive

Delete Found it

Hi @TrystanLea

Some progress. With L68 set to 8 seconds I can control 3 of the commands in DS controlling OpenEVSE.

On Smart Timer. They all return SAVED.

However Off returns openevse Settings Mismatch.


If I switch direct from On to Timer that also returns what appears to be a permanent Mismatch.
I can recover the situation by clicking Smart which returns Saved and then I can click Timer which will then return Saved.
I have tried this maybe 6 times always with the same result.

Thanks @ian

Did you get the fixed timer implementation in the recent update a couple of days ago? When did you last update the system?

Im not sure about the off settings mismatch, what happens if you click between On and Off? does it still suggest in the console that the openevse setting is timer ?

Updated this morning.

On > Off openevse Settings Mismatch consistent as far as I can tell.

Off > On respones varies.

Any Command > Smart seems to recover situation with openevse Saved again consistent as far as I can tell.

Console from On & Off


Thanks, is the car plugged in? not sure that it should make a difference but I think @jpalo did see an issue with this. I cant seem to replicate.

Do you get settings mismatch here as well? what does the console log say?

Specifically Off > On > Off

On Saved

;off to on

Car not plugged in.

Will plug in next lull in Rain!

1 Like

Car plugged in.
No change as far as I can tell.

Starting with DS OpenEVSE off.
Off > On matched
On > Off mismatch with one unresponsive

Interesting that it seems to think its in timer mode when its off… I wonder if there is a firmware difference between my OpenEVSE and yours… I seem to be running v2.7.4, latest is v2.9.1 by the looks of it

I’ve updated to the latest firmware on the OpenEVSE and it seems to still be working ok Tags · OpenEVSE/ESP8266_WiFi_v2.x · GitHub

Mine is ESP32 I think only 8 weeks old.

Powered by OpenEVSE and OpenEnergyMonitor
Version: V3.3.1

1 Like

Ok great, @glyn.hudson is your DemandShaper working fine with the ESP32 OpenEvse? Can you replicate any of what @ian is seeing?

It seems to be, I’ve not noticed any issues.

1 Like