Dataplicity Wormhole & EmonCMS Errors

Bit of a weird one. Have had 21Jul21 running for a while now following a clean install on a new SD card.

As always with my emonPi, I install Dataplicty and use the wormhole feature to view my solar app and manage the pi remotely. Has always worked fine across multiple builds but for whatever reason (maybe a power outage but really not sure) the remote session now throws up errors accessing the app page and will not load. Clicking OK to error just results in spinning wheel.

Note: accessing my emonPi from the IP/local web interface has absolutely zero issues.


I also get errors accessing the Inputs page advising “Device already in use” but other pages seem to have no issues including Admin, Emonhub, etc. I would love to post a screenshot of the Inputs error popup, however it seems accessing the Inputs page from the remote session starts creating new and random inputs.

This ended up breaking my setup and I had to recreate the device/feeds/inputs, and I also reinstalled Dataplictiy, checked for updates, rebooted, etc. but still the same errors.

Accessing my pi page from the IP/locally has absolutely zero issues. Has me a bit stumped.

Any ideas?

I would clear the cache on your browser. Maybe try a different browser. I have build low-write 10.5.6, and have no problems using Dataplicity with Chrome and Firefox.

Yeah have tried cache clear. Same issue happens on my mobile and on another PC. Was working fine on all of them a few (?) days ago.

@glyn.hudson any ideas?
I found a previous thread about flushing redis keys however this only broke my feeds/inputs and I had to set them up again. It resulted in no change to there being errors trying to view the emonpi web interface for apps and feeds via dataplicity despite it working perfecly via internal IP.

Trying the input/feeds pages via the wormhole creates nodes 0 and 30 magically and provides an error stating “device already in use”. Seems to also indicate feeds/inputs come to a halt…

Curiously, the status indicator is red but they keep ticking and updating.

The config error seems to be something caused by dataplicity themselves blocking the JavaScript that emoncms is trying to load. I’ve messaged dataplicity about it but haven’t heard back yet, I need to follow it up

1 Like

Thanks @TrystanLea - hopefully something they can sort out pretty easily, the wormhole funciton is hugely useful to monitor/manage remotely.

I was aboit to question a similar error but on line 498

Hopefully they can sort this quick as it been said its a good feature to remotely monitor a system.

I’ve sent dataplicity a follow up on this question, no luck yet.


We have any update or solution to this yet ?

No response from dataplicity, so I’ve gone ahead and renamed the script that was being blocked from config.js to appconf.js and pushed this to master and stable. If you update the app module it will pull in the fix.

Seems to have caused a new issue with the app module…

Ah, you will need to update the whole system to the lastest stable release v11.0.5

Yep have tried a full update, now getting:

I’ve just run an update and it appears to have sorted the issue for me can now vie my Solar app through Dataplicity.

Components: Emoncms Core v11.0.5 | App v2.5.1 | EmonHub Config v2.1.1 | Dashboard v2.2.2 | Device v2.1.7 | Graph v2.1.6 | Network Setup v1.0.2 | WiFi v2.1.1 | Backup v2.3.2 | DemandShaper v2.2.2 | Postprocess v2.2.4 | Sync v2.1.3 | Usefulscripts v2.3.9 | EmonScripts v1.4.1 | RFM2Pi v1.4.1 | Emonhub v2.3.2 | EmonPi v2.9.5

Good to hear, thanks @BioHzrd, maybe just a browser cache issue perhaps for that final getmeta error…

Yep, cleared cache, rebooted - now cleared. Wormhole also working as expected.
Thanks @TrystanLea for getting this one fixed!

1 Like

@TrystanLea - since fixing this issue, the remote/wormhole session of my pi has been incredibly slow and occassionally times out. Local version is snappy and normal.

Any thoughts before I backup and start a fresh SD card?