Community
OpenEnergyMonitor

Community

Dashboard issues on new install with imported data (Solved)

Tags: #<Tag:0x00007f6e0e2d7e80>

I have now built the new server and after some fiddling, exported the emoncms data from the old (9.2) one and imported it into the new version. Only a trial, the old one is still ‘in production’ so to speak. Both are self built emoncms machines.

However, I had not updated the old version to the newer module structure.

the problem is that the newly imported dashboards have not got any of the ‘graphs’ - they are just empty canvas. Is there any way to fix this?

2 points of note, I could not find the emoncms.conf file on my old system and I have still not enabled Redis (do I really need it?).

[edit]
Just tried to create a new graph and when I click on any feed I get an error;

Request error {"success":false,"message":"Error reading meta data feedid=5"}

Would seem that data has not exported/imported correctly. There is nothing in the phpfina, phpfiwa or phptimeseries directories.

[edit 2]
Realised that the visualisations (that I used before) are there.

[edit 2 - solution]
Once I worked out that the backup had not picked up the data I simply sftp’d the data across and chown it all to www-data (owner and group) and it all seems to be working. Hope this helps someone else.