Daily KWh stuck at null

Evening all, happy christmas etc
I have, for now, a simple setup: emon Tx4 and emonbase, with one CT clamp
That single CT input (P1) reads the power fine
I want to use that one input to write 3 feeds: the P1 power, a cumulative kwh, and a daily kwh/d
Attached are screen grabs from the “Inputs” and “Feeds” page of my emonCMS
My problem is the daily kwh/d feed: it’s just stuck at NULL and never saves any data
I’ve tried deleting all feeds and starting over, and get to the same problem
If anybody has a pointer it would be great (and save me some hair)
Thank you


Hi all! I figure posting in the middle of the xmas break wasn’t smart, so I hope nobody minds me bumping this. Since posting all I’ve tried is “start all over again”, and I get the same result - i.e. a NULL daily KWh feed. Has nobody else encountered this? Thanks!

I think you might have the wrong process.
If you look at what you’re doing:

  1. Log to Feed.
    The ‘Help’ for this (in blue when you select the process) says “Output: Does NOT modify value passed onto next process step.” In other words, it is a POWER that is passed down to…

  2. Power to kWh.
    The ‘Help’ for this also says it is a POWER that is passed down to…

  3. kWh to kWh/d
    The name tells you it’s expecting an ENERGY (kWh)

I think where you’ve gone wrong is that “Does NOT modify value…” refers to the Input - the value received from the step above, not to the value that (in this case) branches off into a new Feed.
You’re feeding it a POWER - the value that originally came in at the top of the list and hasn’t been changed on the way.

Try substituting Power to kWh/d
The ‘Help’ for this says
“Convert a power value in Watts to a feed that contains an entry for the total energy used each day (kWh/d)
Output: Does NOT modify value passed onto next process step.”

Hi Robert, thanks for taking a look!

However your suggested change is what my process is already doing: step 3 of my process is “Power to kWh/d”. Like you say, this step is expecting a Power; and that’s what it should be getting, since step 2 (Power to kWh) doesn’t modify the value passed on to step 3…

Oops. How did I read that step 3 as as kWh to kWh/d?
In this case, like Brian, I don’t see why it doesn’t work.

You are leaving it long enough, i.e. from midnight to midnight plus a bit, before you see the output; though I think this shouldn’t matter - I set that process up on a feed some minutes ago, and I’m seeing 0.03 kWh/d on the Feed page, though nothing yet on a graph. Caveat: I’m not using the latest emonCMS.

As a workaround, try Power to kWh followed by kWh to kWh/d
If that works, it’s pointer to where the problem might be.

The code should (used to) be at /var/www/emoncms/Modules/process/process_processlist.php if you want to take a look.

Thanks Robert, I’ve got a fudge solution to show me my daily usage by using a visualisation (daily bar graph, with delta ‘on’)

But that’s slightly disappointing as I planned to see and manipulate the daily data differently. It’s still stuck at NULL… The weird thing is that I have another completely separate setup with the same process which works fine

I might try and dive into the code but expect to be out of my depth almost immediately!

Hello @coltcc

Do you see any errors in the emoncms.log by any chance that might relate to this?
Im wondering if something else might be blocking the saving of phptimeseries data specifically on your system… can you log a feed to a phptimeseries feed without the power to kWhd process? does that work or does that also show NULL I wonder?

It seems to be working fine for me here, I can see the data recording to the phptimeseries kWh/d feed at midnight and I can retrieve that value using the graph.

Hi Trystan
No obvious errors in emoncms.log
I can create a simple “log to feed” using a variable interval and that seems to create a PHPTIMESERIES which is non-NULL and can be graphed as normal, so it must be something else, mysterious…
Thanks for having a look!

Hi Trystan
I did a “full update” and it seems to have fixed it! Don’t know why I didn’t do that sooner - the gear is only a month or so old so it didn’t occur to me to try updates