Daikin Altherma, ESPAltherma & Home Assistant with OpenEnergyMonitor

My Octopus install is coming up. I’ve got my cable ready. ~2m ethernet with a female 5pin JST EH 2.5mm on one end and 5 pin male dupont on the other end (for the M5StickC Plus2).

Since Octopus will be installing an outside consumer unit, would it make sense to ask them to run my extra cable into the CU as part of the install? Then all I’ll have to do is isolate power, plug in the M5Stick in the CU and plug the other end of the cable into the X10A port.

They’ll be running wiring from the pump up into the loft (and down into the airing cupboard) so I’m also going to ask them if they can run an Ethernet cable at the same time in case I end up wanting Ethernet out there later on.

My plan is to have plenty of biscuits so hopefully they’ll be in the mood for these requests :grinning:

1 Like

I am hoping the will fit my M5 Tough for me and the Shelley in the consumer unit. I will have my planning permission decision by the end of the week. Please let us know if they do it all for you.

I’ve got my ESP device set up and finally got around to adding the Shelly EM to get accurate power readings for the heat pump. Everything seems to work ok in home assistant as I now have the COP reading coming through in Home Assistant.

I am not looking at how I get the data into emoncms. I’ve got the following configuration in the configuration.yaml file in homeassistant:

sensor:
  - platform: emoncms
    api_key: 'myapikey'
    url: https://emoncms.org
    id: 1

emoncms_history:
  api_key: 'myapikey'
  url: https://emoncms.org
  inputnode: 1
  whitelist:
    - sensor.espaltherma_cop
    - sensor.espaltherma_heatpowerout
    - sensor.espaltherma_fanspeed
    - sensor.espaltherma_flowsensor
    - sensor.espaltherma_waterpressure
    - sensor.espaltherma_inletwatertemp
    - sensor.espaltherma_leavingwatertempbeforebuh
    - sensor.espaltherma_lwsetpointmain
    - sensor.espaltherma_extindoorambientsensor
    - sensor.espaltherma_indoorairtemp
    - sensor.espaltherma_freezeprotection
    - sensor.espaltherma_operationmode
    - sensor.espaltherma_outdoorairtemp

However on emoncms.org under my inputs I only get the senor.espaltherma_cop coming through in my inputs. Could someone explain how I get all the sensors?

Have you done a full restart of Home Assistant? I think I found that necessary. A YAML restart was not enough IIRC

I have this project coming up. Did you have to install the Shelly Integration into Home Assistant?

Yes I’ve done a full restart.

The Shelly just appeared as a new device on HA. I just needed to get the device name to add it for the CoP calculation.

1 Like

I am no electrician. I wish I could wire it up to just get it on the network.

I have inputnode set to 19 in my configuration.yaml, taken from the settings earlier in the thread. I don’t know if that’s a magic number or not.

So I’ve solved it by loading emoncms locally on a Raspberry Pi 3 I had laying around spare. So not quite sure what the issue was. Now I can’t work out how to map all the sensors to the heat pump app, but that can be a job this week to work through it.

I currently run Home Assistant and have the Daikin integration, but hate the delay and lack of sensors and unable to see my COP.
I’m looking at purchasing this; https://www.amazon.co.uk/dp/B071P98VTG
As well as a pack of Dupont wires. I’ve read a few guides for ESPAltherma so I’m somewhat confident I know what to do, just checking that the linked ESP32 will work with my Daikin Altherma heat pump? and what pins on it should I be using?

My router is directly on the inside of the wall where the outside unit is, so I’m hopeful that won’t be an issue.

The ESP32 would work fine, but obviously would need protection for the pins etc. The M5Stick is a bit more expensive, but comes in a good case and the connections are well documented.

What model is your Daikin?

You should refer to the GitHub material for ESPAltherma for pins and so on. Check the header files in include/def for your model if it’s not one of the EDLA/EBLA ones.

I own a 3d printer and already found cases that will fit that ESP32, so i’d print one of those out for it. I’ve looked at the m5stickC, and it’s about £22 delivered, compared to £9 for the Amazon one. If the M5StickC makes it considerably easier, I’d potentially go for it.

My model is a Daikin Altherma 3 Monoblock EDLA04E2V3

Sounds good. GitHub says “
For ESP32 try to stick to the RX2/TX2 of your board (probably GPIO16/GPIO17)
” - that dev unit has G16/17 marked on it.

The include/def files have an EDLA D-series 4-8kW definition, according to the file name. That would be my starting point. I don’t know anything about D vs E series, but I compared the EDLA09-16D and EDLA04-08D files, and none of the normal values for monitoring are different, so it seems relatively unlikely that Daikin have changed much in that respect. You’re not going to break anything if you query the wrong registers, you’ll just get unlikely data or an error.

1 Like

Thanks for your help :slight_smile: I’ll get the ESP32 and give it a whirl.

I am going to use an M5 Tough. @1nc has forked the code to run on the M5 Tough. He has his working. Mine is flashed, but I am minus a heat pump until July 22nd :grinning:

Done and hooked up! It was pretty easy to do, and it worked immediately after turning the heat pump back on at the switch. I think the wifi is just on the brink of being okay, too.

Which heat pump do you have? Which file did you use for it and which sensors did you uncomment?

I’ve put my model in a comment further up, but it’s the Daikin Altherma 3 Monoblock EDLA04E2V3. The screenshot shows the values I uncommented apart from Voltage which I added after this, this wasn’t listed to uncomment, but I manually added it in and found that my Heat Pump supports it and provides the value for me ;
{0x21,4,101,2,-1,“Voltage (N-phase) (V)”},
And by doing Voltage x INV secondary current (A), I get the wattage for the Heat Pump.

1 Like

In case you’re interested - you’ll be able to get a proper value for water pressure as well by changing the water pressure line to this:

{0x62,11,105,1,2,"Water pressure"},

Here’s a github reference: New definition file - Water Pressure wrong EBLA-EDLA D series 4-8kW Monobloc · Issue #379 · raomin/ESPAltherma · GitHub

Wish I had known about this before I had my Shelly installed! Does it appear to be accurate?

1 Like