Community
OpenEnergyMonitor

Community

CT sensor on heat pump monitor showing low values

Tags: #<Tag:0x00007f6e09a5b828> #<Tag:0x00007f6e09a5b6c0>

Hi

I have just setup a Heat Pump Monitor with temp sensors and a CT power sensor. Problem is, the CT sensor is giving very low values. I’m connecting to the same wire in my Heat Pump as i was using for a traditional electricity monitor i got free from British Gas - which was reading ok.

Have i set something up wrong on emoncms, or do i need to configure anything on my Heat Pump monitor maybe? Im using the CT2 port on the heat pump module.

btw…the heat pump monitor was really easy to setup - attaching the temp probes a little fiddly for a amateur like me :wink: but it didn’t take long. Had to dig around the forums a bit to find out which wire goes into which terminal! Nice bit of kit!

Pete

so have attached my old British Gas elec monitor too to compare now. When CT sensor records 9 the british gas monitor displays around 4.5Kw. Any ideas why?

I haven’t got or built one, so I can only offer general hints as to where to look…

9 W could well be only noise pick-up.

What does the inputs page of emoncms look like - is it sensible? i.e. are you using CT2 to send to GSHP Power?
What does the Arduino IDE serial monitor show for CT2?
Is your CT connected - can you measure around 100 Ω between tip and sleeve on the plug (not plugged in of course)?
Was the plug fully inserted? (yes, it sounds silly but…)
What does CT1 read when you plug in there?

Thanks for the reply Robert. I’ve tried CT1 and 2, same result. Was checking it was plugged in as i saw that was an issue sometimes :wink: Sounds like its not reading at all then. I have another CT clip on my EmonPi elsewhere, i’ll swap it for that one as i know that works and give that a try.

here’s the emoncms inputs page…