Community
OpenEnergyMonitor

Community

Corrupted virtual feed breaks the feed list

Tags: #<Tag:0x00007f6e03d15f10> #<Tag:0x00007f6e03d15e48> #<Tag:0x00007f6e03d15d80>

I added a virtual feed to my feed list, and because of my general lack of knowledge of how Emoncms works I foolishly had it use itself as its source feed. Now my feed list won’t load because I believe it is trying to have this virtual feed read from itself and is getting stuck in an infinite loop. Most everything else is still working and rebooting the Emonpi didn’t help.

Is there a way to delete a feed other than through the feeds page?

-Berkeley Fergusson
CS Intern SolarMill

You could do it via mySQL or use phpMyAdmin if you get really stuck, but firstly you could try using the feeds api, examples and explanation can be found via the emoncms menubar.
You probably won’t know the feed id off hand so first get a list of feeds and then identify the culprit and zap it with a “delete feed”. the benifit of doing it via the api is that it will remove the feed data, meta and the reference to it in the feeds table, as well as redis. All this can be done manually but it’s easier when you use the right tool.

1 Like

Trying the feeds api didn’t work (the browser window gets hung and times out). I know very little about php and sql could you explain how to fix it through the mySQL or the phpMyAdmin? Are virtual feeds stored in the same place as a normal feed?

We tried to delete it by entering the following address in our web browser and the page times out. (The feed ID is #126) " http://10.1.10.200/emoncms/feed/delete.json?id=126 "

Is there a terminal command we can use to delete feed id 126?

-Berkeley Fergusson

Did you try the last api on the feeds api help page, by deleting the feeds processlist that may help by removing the reference to itself and break the cycle.

Is the feed actually still there? if you list the feeds again, is it still there? have you tried flushing redis or restarting the server? The trouble being the feeds will probably be loaded to ram and the looping will not take any notice of the attempted changes to the sql tables. you may need to stop the server and use phpmyadmin to delete the processlist of that virtual feed and then restart the server or better still reboot.

You can easily install phpmyamdin using sudo apt-get install phpmyadmin, you will need to know your root mySQL password, there will be a generic one if using a pre-built image but I do not know what that is off hand.
Once installed you can log into phpmyadmin by navigating to http://yourserver/phpmyadmin.
Once logged in you can locate and delete just that feed’s processlist which should break the cycle without leaving you with loose ends to delete or tidy up.

1 Like

Success!
We tried the delete feeds process list to no avail.
The problem we were having was we were unable to display the feeds list page at all.

We tried redis-cli -r 1 flushall and that didn’t seem to help.

We then logged into phpmyadmin and deleted the feed from there, rebooted the system, and the feeds list was back.

Thanks for your help Paul.

-Berkeley Fergusson

Update 2: found the username and password in the changelog here.

Deleted the feed, restarted and it’s fixed.


Update: So I managed to get my access back to phpmyadmin by following some steps found online, including some configuration files in the right locations.

Now, I can’t locate the default username and password anywhere to log in phpmyadmin.

Where would I find that?

Thanks,


Hi,

I am having the same issue (that’s what you get for trying things without reading the instructions).

I have installed phpmyadmin as stated above but I am unsure about the next step on how to access phpmyadmin.

I have the folder under /usr/share/phpmyadmin but I’m not sure how to access it to delete the problematic feed.

Any help on where to go from here would be much appreciated.

Thanks,
Perig