Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Corrupted SD card on emonpi after power cut

Just had a power cut which seems to have corrupted the SD card on my emonpi, with the emonpi screen stuck on “raspberry pi booting…”. It is still however sending data to emoncms.org OK. I’ve ordered a new pre-loaded card from the OEM shop. Anything else I could try to get the emonpi to boot while I’m waiting for the new card?
Jez

Hi,

have you tried a controlled re-boot?

John

John - what is a controlled reboot? I have tried pushing the reset button on the emonpi but it doesn’t respond.
Jez

If it is still sending to emoncms.org, it is likely to be OK.

Can you SSH in?

Yep - I can SSH in using putty. I can also log on to the local emoncms on the emonpi. The image is quite old (9.8.25 from 2017). I normally just use emoncms.org for my data so rarely access the local system.
Jez

So definitely suspect the SD card but may also be because of the old image and the message to the LCD not getting updated correctly.

Had you run an Emoncms update at all?

Update the image and use the USB method to restore your data & settings might well solve the issue.

Thanks Brian - I’ll try the update option in a few days time. I’ll let it run as it is for the time being as I’m running a long term experiment on my heat pump and don’t want to risk losing the data - and the data is still being uploaded to emoncms.org despite the emonpi screen still showing the booting message
Jez

The push button and LCD are both managed by the same script so it could be that just that one service is not working or has an issue. If you check the emoncms admin page does it show any issues with the lcd service?

There was a issue with updating the lcd service many moons ago where the config file was moved or altered and users had to do a manual edit. Maybe someone else has better recollection.

I certainly wouldn’t assume the image is automatically a write off just because the lcd and button isn’t working, especially if it’s still posting to emoncms.org.

I’d agree, but it is running 9.x which is a long way behind so trying to debug it is a fool’s errand.

I don’t think an (emoncms) update was done to have changed this.