Clone Dash Problems

I have a strange issue whereby the clone dash board button works fine as admin but does nothing for other user accounts.

running 9.7.2 | 2016.07.04

thanks in advance for any ideas.

This sounds like a bug, please open an issue on the dashboard module repository

Done I have reported as a bug

Where is this clone dash button?
I’m unable to find more info about this.

Go to Setup > Dashboards


and then click onof the dashboard you want to clone.

Thanks @Jon , didn’t know what that button was for actually. :slight_smile:

I didn’t know until last week when I clicked it by accident! :smile:

Has anyone else got the same issue as @dafyddhirst, where dashboard clone does not work for non admin? It works on for non admin users

I havent tried it on emoncms my self s i run my own server.
@glyn.hudson i can give you remote access to this if you wish to look.

Sure, that would be great. Please pm me your details. I’m away from home
this next week with limited connectivity so I may or may not get a change
to look for a few days.

  • sent from my mobile device

Seems to work fine on my self hosted emoncms here. Also 9.7.2

Is that as an account other than the administration one?

Get Outlook for Android

Sorry, forgot to mention.
Yes it works with an account other than admin!

The plot thickens …
Ok i have 3 user accounts n this server
user 1 can clone any dash
user 2 cant clone 90% of dashes
user 3 can clone any dash

Any ideas if its something in the database that could cause this?

it seems some dashboards can be cloned come cant for the affected user. out of 23 dashboards i have only been able to clone a very few for the affected user…

the published / listed / unlocked status does not seem to affect it.

i will create some more users and see if the problem persists.

Can you see any other patterns, for example in the naming, use of special characters or spaces etc. Or is there anything different on the dashboards that won’t clone eg specific widgets or formatting?

i had similar problems, not all dashboards would clone some did some didn’t, the problem was if the names exceed 24 characters and strict mode on mysql was enabled, which is on by default in mysql 5.7+.

The problem is that when strict mode is enabled and you supply a varchar fields value that’s longer than the field can handle for example varchar(30) field and value is 40 characters, the sql statement will fail. if strict mode is NOT enabled it will cut off all extra characters and the sql statement will not fail

to rule out it’s the same problem see if doing this fixes the problem as it fixed all problems i had with this.

see the other issues i had related to this here Emoncms 9.7.3 can't clone dashboard + toggle published problem