Changing an emonTH2 channel

I have tried to change the channel used by an emonTH2 by moving the two DIP switches to both be on. However, the emonHP is still see it as being input emonth2_23. I have tried deleting it, but it still comes back as emonth2_23. Am I missing something - I want this feed to show as emonth2_26 since it conflicts with another emonth2 on - and is therefore rather confusing.

There was a lot of oily looking stuff on the switch - could that be the issue?

Did you take a battery out and restart it?

The switches are only read at start-up, so if you didn’t, they weren’t read and nothing changed.

Yes, I did that. It still came back on channel 23.

I think I’ll try to figure out how to stop one of my emonpi / emonth2’s sending up to since I’m really only interested in logging this new one.

Is it still 23 in emonhub.log? (I’m wondering if emonhub.conf has got the wrong nodename attached to the Node 25 ID?)

If the switches are now closed, I wouldn’t expect any contamination to affect them. Open, then maybe.

I think the only way to prevent from logging data is to not have a ‘Log to feed’ statement as part of the input processing there. I don’t think there’s a way of not sending a single value to and still sending all the rest.

Hi - and thanks for the replies. I’m wondering if I could edit the EmonHub config file in some way. I think I could exclude one of the sync’d entities, but I would prefer to be able to see it in some way on . I really would like to fix the issue properly by having this new EmonTH2 on a different channel. I have tried several times to alter those DIP switches and they seem to click to the new position but don’t alter the channel. For some reason the hardware just doesn’t seem to take any notice. I think I’ll log an issue with it, or I guess I could wait and see if I can change the other one when I get home.

I looked at the code the last time you posted and I replied, I couldn’t see a reason for the switches not working. I have a V2.0.2 here, I’ve checked it and the bad news is, it’s behaving exactly as it should for me - I can get it reporting as Node 23, 24, 25 & 26, both to the serial port and to emonhub log file.

Stupid question: Are you looking a fresh data, not something cached somewhere?

Check the voltage across the switch – ON it should be zero, from 3.3 V OFF. If the voltage stays at 3.3 V, email The Shop because it’s faulty switches: [email protected].

Do you have a programmer and the Arduino IDE? If so, the next easy way is to change it in software and reload the sketch.

How is this emonTH’s data getting to, and how is the other emonTH2’s data getting there?

You can certainly edit your emonhub.conf via a web browser and emonCMS.
Setup → EmonHub → Edit Config. Look for the section starting [[23]] Mine looks like this:

        nodename = emonTH_5
        firmware = V2.x_emonTH_DHT22_DS18B20_RFM69CW_Pulse
        hardware = emonTH_(Node_ID_Switch_DIP1:OFF_DIP2:OFF)
            names = temperature, external temperature, humidity, battery, pulseCount
            datacodes = h,h,h,h,L
            scales = 0.1,0.1,0.1,0.1,1
            units = C,C,%,V,p

nodename = ... is your choice – whether it gets to depends on the path it takes.

You have got entries in your emonhub.conf for the emonTH nodes you are/want to use?

Thanks Robert, that is really helpful.

I checked the voltages, and have confirmed that I have DIP1 OFF and DIP2 ON. I then pulled out the batteries, deleted the feed, and then replaced the batteries. The feed came back again as emonth2_23. Something isn’t correct! It is as though the DIP switches are not being read…

I guess I will log an issue with the shop?

What version of software do you have?

You didn’t answer about the programmer.

When I fire mine up and watch the serial output, left on Node 24, I see V4.1.5:

10:36:41.671 ->
10:36:41.671 -> emonTH FW: V4.1.5
10:36:41.803 -> Loaded EEPROM config
10:36:41.803 -> Group 210, Node 24, Band 433 MHz
10:36:41.803 -> pulses enabled = 1
10:36:41.803 -> pulse period = 50 ms
10:36:41.803 -> DS18B20 enabled = 1
10:36:41.803 -> DS18B20 found = 0 of 4
10:36:41.803 -> RF on
10:36:41.803 -> Serial on
10:36:41.803 -> RF power = 7 dBm
10:36:41.803 -> RadioFormat: LowPowerLabs
10:36:41.803 -> Init RFM...
10:36:41.803 -> RFM Started
10:36:42.900 -> Int SI7021..
10:36:42.900 -> SI7021 Started, ID: 21
10:36:43.033 -> temp:14.48,humidity:78.65
10:36:43.166 -> '+++' then [Enter] for config mode, waiting 4s...
10:36:47.400 -> temp:145,humidity:786,batt:0

Looking at the changes for the V2.0 hardware, the DIP switches seem to have been a repeating source of trouble:

  Change log:
  V4.1.5   - (21/08/23) Fix node ID DIP switch selection 
  V4.1.4   - (21/07/23) Serial print RF format  
  V4.1.3   - (05/06/23) Startup serial print streamline for factory test 
  V4.1.2   - (27/02/23) Add option to used custom encrpytion key
  V4.1.1   - (19/02/23) Fix missing frequency initialization
  V4.1.0   - (17/02/23) LowPowerLabs radio format option
  V4.0.0   - (10/07/21) Replace JeeLib with OEM RFM69nTxLib using RFM69 "Native" packet format, add emonEProm library support
  V3.2.4   - (25/05/18) Add prompt for serial config
  V3.2.3   - (17/07/17) Fix DIP switch had no effect
  V3.2.2   - (12/05/17) Fix DIP switch nodeID not being read when EEPROM is configures
  V3.2.1   - (30/11/16) Fix emonTx port typo
  V3.2.0   - (13/11/16) Run-time serial nodeID config
  V3.1.0   - (19/10/16) Test for RFM69CW and SI7021 at startup, allow serial use without RF prescent
  V3.0.0   - (xx/10/16) Add support for SI7021 sensor instead of DHT22 (emonTH V2.0 hardware)