Community
OpenEnergyMonitor

Community

Cant get service-runner enabled and running for backup to new SD install on EmonPi

Tags: #<Tag:0x00007fc9bd40c818>

I have looked at the Backup part of the EmonPi and there is a footnote at the bottom starting : Warning: service-runner is not running and is required. To install service-runner see service-runner installation.

when i go to the link and try the commands through putty to help get it started and running i do no good at all these commands are:

sudo pip3 install redis
sudo ln -s /var/www/emoncms/scripts/services/service-runner/service-runner.service /lib/systemd/system
sudo systemctl enable service-runner.service
sudo systemctl start service-runner.service
systemctl status service-runner.service

Any ideas that might help get this service_runner going?, as i have about 18 month of data to backup and up load into the newer July 2020 emonPi image.

Do you actually have an emonPi - that is the hardware, the software you are accessing data through is emoncms.

Your best route is to get a new SD Card and do a direct import. Follow this guide.

I have just tried by installing new 24jul2020 card into emonpi and booted up without trouble, all services are running, i put the old sd card into a SD to USB adaptor, went to the backup page to import from USB drive, it found the SD card but will not update, just has the list of drives, one with the SD card in it, I have refresh it many time without any sign of uploading from the old card to the new, even after a reboot, still no further past the same screen

Yes the problem is the large number of different strings USB card readers report as.

If you can, this will solve the problem Backup module usb-import.sh script (beta)

In your case it will need to read

usb=$(ls $disk_id | grep ‘usb-USB2’)

@TrystanLea @emrys with more people using this it needs to be fixed. I suggest a popup that allows the user to select the device to be used for import.

My biggest problem is i can’t read the SD card from my Win10 PC, I can only read the :boot" partition and not the other partitions to be able to change the text

Ah no, you need to edit the file on the emonPi.

sudo nano /opt/emoncms/modules/backup/usb-import.sh

It is a PITA I know.

I will check it out tomorrow morning, getting a bit late here in the land of the down under :smiley: :smiley: :smiley:

1 Like