Community
OpenEnergyMonitor

Community

Can't delete app

apps
Tags: #<Tag:0x00007f1fdde8aab8>

(Chad Smith) #1

I created a ‘time of use’ app the other day, which I now can’t delete.
I remember when I made it that I put a special character in the name. I think it was a /, because I wanted to call it ‘Peak / Off Peak’.
After the app was made, it only called it ‘Peak’ in the app list.

The app loads and I can access the config, but when I press Delete it prompts “ERROR: App does not exist with name Peak”.
It’s as though the special character that was in the app name truncated it, but despite the app name matching that in the error message it still won’t delete it.

Is there a way to either delete the app manually, or to rename it?


Using Time of use - flexible
(Inactive) #2

Try this:


(Chad Smith) #3

@overeasy, thank you that did the trick.

I noticed the name of the app url was incomplete just like the app name. I applied this part url exactly as is in the ‘remove’ url and it worked.

As reference for others, my app url looked like this. I took the part “Peak%20”.
/emoncms/app/view?name=Peak%20&readkey=1e7…


(Jabe BABE) #4

I have the same problem as the original poster. Yet I put in an nonenglish letter and the process worked for one of the apps but not the other.

When I list my apps in get the following message:
"T\u010c - My Electric ":{“app”:“myelectric2”,“config”:{…and so on

and when I try to delete it, I get this:
{“success”:false,“message”:“App does not exist with name T\u010c - My Electric”}

I have tried many options for the letter “Č” and none of them successful.
Anyone knows how to help me?


(Jabe BABE) #5

After many more tries and combinations I was succesful.

In the url I had to put the nonenglish letter “Č” and let the site convert it to T\u010c. AND there was a space in the name at the very end, so the solution was:

http://emoncms.org/app/remove?name=TČ%20-%20My%20Electric%20


(Inactive) #6

Very resourceful. This solution is a kludge at best. An app or function in an existing app that turns around the name it receives from Emoncms seems to me to be a better solution, or fortifying the apps themselves so they can get past the config errors to their inbuilt delete function. Unfortunately that’s way outside my area of involvement with the project. This has come up at least three times in the last couple of months, so maybe it will get some attention.


(Paulo Azevedo) #7

Thanks for the tip. I’m currently testing version 9.9.8 and this “Time of Use” app keeps having some issues, as soon I create it, it gives some errors. Then deleting it was impossible, only via manual command:

http://192.168.1.168/emoncms/app/remove?name=Time%20of%20use

Cheers!