Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Cannot update Feeds names or view Feed Values (and seconds since update) in mobile version 10.1.13 on Android

Tags: #<Tag:0x00007fc9bd79aa98>

Hi Team,

I just updated from 9.9.8 to 10.1.13 - some nice touches but some regressions that I find serious, so much so that I’ve rolled back to 9.9.8 immediately. The ‘bugs’ that I have found are the following:-

  1. in feeds menu, when using a mobile phone, if you try to edit the feed by hitting the edit button at the top of the window, there is no apparent method to edit the name of an individual feed - it picks one feed, and that’s your only choice.
  2. I’ve always used the feed screen as a way to quickly glance over the data flowing from each feed (ie last updated / value) - on android these values do not show - only the feedname shows for each feed, no value.

In our particular implementation we use the feednames as a way to send messages to our nodes - we encode commands in the feed names - it’s unusual, but names were one of the few ways we could find to do that… they can be changed easily. We’d just create blank feeds and use them as ‘command sending feeds’. our arduino ‘nodes’ poll feed names every couple of minutes and if they see that the name has changed they pull the new name, interpret the encoded ‘command’ and execute… Not being able to update feed names in mobile is a tricky problem for us.

I’ve tried forcing android to use ‘desktop view’ but unfortunately it makes zero difference.

Latest version is 10.1.13

@emrys - could you have a look?

1 Like

Thanks Borpin - Typo - it wasn’t 10.1.1 - I did a git pull - absolute latest release.

Cheers,

M

1 Like

IOS or Android?

Works for me on Firefox on Android.

Select the checkbox, and then click on edit icon.

Selecting the feed was a little tricky, not sure if that is the interface or my fat fingers.

Landscape?

Brian no checkbox for me on android, chrome. Your feedlist looks completely different to mine in terms of the fact that there is a) no checkboxes on mine and b) no value column and c) no seconds update. I’ll try again in the morn and give a definitive answer re version. Thankyou for your cycles and interest in ‘the issue’.

Are you logged in?

Can you post a screenshot?

Just tried Chrome and it works for me.

Try clearing cache or open in a private window.

1 Like

Hi Brian,

This is a self hosted emoncms installation and yes I am logged in.

I’ve just reupdated using ‘git pull’, installed firefox just for giggles, tried opening in a private browser tab - still no dice.

Hell, I’ve even tried restarting my device.

Android shows no update times or check boxes. Screenshots are attached. I can confirm version is 10.1.13. I can also confirm that neither landscape mode nor desktop mode makes any difference… the latter seems quite unusual as the checkboxes etc do appear if accessing this from my laptop PC.

Most odd.

Are you on the same network?

HTTP or HTTPS?

Can you try accessing by IP instead of domain name (clutching at straws here - just trying to see what might be different).

I’ll try by domain and HTTPS tonight.

Brian,

Not on the same network. https on shared server hosted by A2 hosting, so therefore I can’t access directly via IP… it also doesn’t matter if I use the https or non https version - same problem.

I’ve been clutching at similar straws!

fyi it’s only the feeds module that has this issue… the inputs module renders normally (with checkboxes and seconds etc)

Not quite self hosted then :grin: (by that we mean on a local machine - we’d refer to your setup as shared hosting). It does make a difference.

@TrystanLea, @emrys could you look. I wonder if some of the Javascript is not being passed correctly off the remote host.

@dockarl does it work on a laptop OK? Any errors in the console?

No errors on console… and… usually… works well on laptop… but opening the console on my laptop just now, in chrome actually ‘replicated’ the error! See screenshots below… first with the console open, second with the console closed. There is no scroll bar on the bottom so it’s not just that I haven’t scrolled far enough to the right.

Please note that in the interests of ‘having a guess’ - whats unusual about this implementation is that some of my feed names are very long… up to 120 characters.

Might be related to this problem then. Missing input name

Can you raise this as a GitHub issue? Refer back to this thread as well.

No spaces at all in my feednames… they’re like XX12:XY24:DY345:GH685 (etc out to 120 characters).

that may be confusing the column alignments.

yes, the long feed names will mess up the column widths. Here are 2 examples; one with long and one without long names:

|

| |

I can see that the tick-box is shifted off screen here and then cannot be selected to change.

This is a similar issue to the one listed above:

The interface will need to be changed to accommodate the larger input and feed names.

I’ll post back here when issue #1480 is looked at

1 Like