Cannot reset or connect WiFi MQTT Relay

Hello, just received this today (WiFi MQTT Control Relay Thermostat - Guide | OpenEnergyMonitor), plugged it in, little blue LED came on, private OEM_185 AP available, connected, and entered my password for my own WiFi, it rebooted, and… it doesn’t connect. So now I am trying to reset it by holding the little button for 3 seconds, but nothing, I cannot get it to enable it’s own AP again.
I’ve tried holding the button longer than 3 seconds, but no luck. Power cycling, no difference.
How can I reset it please?

Sorry to hear you’re having issues. Are you sure it’s not already connected to your WiFi network?

Pressing and holding the button for 3s should turn on WiFi AP. Once in AP mode pressing for a further 3s should factory reset the unit.

To find out exactly what’s going on we will need to see the serial debug output. Do you have a USB to serial programmer you can connect to the UART header to read the serial output at 115200 baud?

Hi Glyn

It is not connected to my wifi. I have made certain of that. And the wifi signal is excellent in the room (there are multiple UniFi AP’s all within proximity).

Afraid I do not have a serial programmer sorry.

I have tried holding the button for several seconds and it simply will not restart the private AP. Is there any other way to reset it?

Thanks

I’m afraid any other method will require a USB to serial programming cable. We would be happy to send you a programmer cable free of change to see if you can debug and fix the issue?

Or you could return the unit to us for testing?

IME, multiple APs (with same SSID) can be the cause of the problem and not the solution and I’ve had all sorts of issues with UniFi APs and ESP8266 gear (and Android tablets, but that is another story).

My issues got so bad that I now use these cheap routers, flashed with OpenWRT for my IOT gear to connect to.

YMMV.

Thanks Borpin, the thing that is puzzling me is that the device will not reset and start it’s own private AP. That doesn’t suggest a problem with Unifi (at this stage), but I’ll bear that in mind if I could actually get to the menu to try.

Thank you Glyn, yes I’d like to try that please, and will share the findings here.

Hello Glyn,

I connected the USB UART and the device was in a boot loop, printing the below text:

 *.... garbled text...*
ets Jan  8 2013,rst cause:2, boot mode:(3,6)

load 0x40100000, len 2592, room 16 
tail 0
chksum 0xf3
load 0x3ffe8000, len 764, room 8 
tail 4
chksum 0x92
load 0x3ffe82fc, len 676, room 4 
tail 0
chksum 0x22
csum 0x22

2nd boot version : 1.7(5d6f877)
SPI Speed : 40MHz
SPI Mode : QIO
SPI Flash Size & Map: 16Mbit(1024KB+1024KB)
jump to run user1 @ 1000

*.... more garbled text, and repeat...*

So, I reflashed the firmware, and voila! It works! I have set up the WiFi config and it has connected OK and I’m able now to access over my WiFi. So far so good.

I have also created a PR here Correct the firmware filename shown in the esptool command, and added… by butako · Pull Request #2 · openenergymonitor/mqtt-wifi-mqtt-single-channel-relay · GitHub to update your docs with notes that I found helpful to the process. I hope this is ok.

Also initially I did not know which way around to connect the CP2102 board to the Relay, AFAICT there is no clue on the PCB, and could not find anything in the online docs/forums either. So I got lucky and guessed.

Happy it’s now working and on to the next step of wiring it up to my immersion heater! :slight_smile:

Thanks!

1 Like