Cannot connect to new emonPi over wifi without ethernet cable attached

I received my new emonPi this morning (quick work - only ordered yesterday afternoon!) Connected via ethernet - and after several attempts configured the local wifi using the configuration screen. Now, on powering up the LCD shows wifi yes, but when I type the ip into Chrome there is no response from the emonPi until I reconnect the ethernet cable. This means I cannot install the device as there is no ethernet in my meter box. Any help appreciated.

Tried to SSH in using putty, but was very confused for a while as (after holding the button for 5 seconds) the display clearly shows the password as emonpi2018, and it seems it is still emonpi2016 !!

OK - using SSH over an ethernet cable did a factory reset, the emonPi set up as a wireless access point, removed the ethernet cable, and connected to the AP ( no password required) and entered details to allow the emonPi to connect successfully to the local Wifi. So problem solved. Would still be interested to know what caused the above issue, and how it could be resolved without a factory reset.

To follow up - I had my recent success configuring the emonPi wifi in a different house from the one I did the original testing which is where I intend installing the emonPi. When I returned to install it, I initially again could not get the emonPi to connect to the local wifi. After much head scratching and confusion, compounded by lack of familiarity with the system, and a screen that doesn’t refresh, it seems the problem was that the Pi was unable to connect to the wifi because it had a numeric WEP2 WIFI key. I have never come across this obscure problem before. Anyway, I created a new SSID with an alphabetic WEP2 key,and all works well. Has anyone else come across this issue?

Hello @wmcausland, good to hear you have it up and running now. I’ve double checked a numeric WEP2 WIFI key here and it worked ok. However I did come across a bug that limited the minimum number of key characters to 9 instead of the 8 character minimum that it should be (now fixed minimum strlen should be 8 by TrystanLea · Pull Request #19 · emoncms/wifi · GitHub). Could this have been part of the issue?


Yes - the key had 8 numeric characters! Brilliant to have resolved that one. Many thanks for your support.


great to hear @wmcausland