Community
OpenEnergyMonitor

Community

Cannot access WiFi AP after uploading from VSCode/PIO

I’ve checked out master from the EmonESP repo, and using VSCode with PlatformIO to build/upload. It’s compiling, uploading (both code and SPIFFS) without an issue. I’m using the default project tasks in VSC. I always do an erase before uploading. After a successful upload, the AP appears on my phone, but it’s very hard to connect to it, it has a pretty flaky AP. When it succeeds, it almost instantly drops the connection. I’ve also tried flashing a Tasmota .bin that used to run on this device previously. It works without a hitch on first try, so my setup an the device is working just fine. The device is a generis ESP12S NodeMCU clone with 4 MB flash. I also tried to flash the code and the spiffs using esptool.py directly, to the same effect, sadly.

Am I missing something? Could please someone guide on how to debug further?

Additional info - the content below is repeatedly displayed endlessly on the serial console of the module:

Commencing factory reset.
ÿactory reset complete! Resetting...
 ets Jan  8 2013,rst cause:2, boot mode:(3,7)

load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d
v8b899c12
~ld

EmonESP 7337
Firmware: 2.3.0
Starting APScan: 3 networks found
AP IP Address: 192.168.4.1
Server started
Commencing factory reset.
...

Solved by downgrading to [email protected] (Arduino Core 2.4.x).

Hi,
this looks like the problem I was experiencing. I have not looked at loading EmonESP for some time (distracted by other things), & I am no programmer.
I ask: Perhaps its time the source was updated to compil;e under the newer compilers?? Especially if pre-compiled code is not available.

regards, Doug