Can openEVSE default be set to Eco Mode?

Hi thanks for the reply I will try and use mqqt. To enable and disable the pv function. Based around my normal charge times . And give it a go …
this is looking good when it is operating
Will let you know how I get on
Thanks

Regards. Bill

Hi Glyn
Ok I have managed to use node red to set up the solar Eco divert to a timed shedual. From 9 am to 4 pm it will do solar / export excess charging now .
Could I ask if it is also posable to change the state of the solar PV divert enable command that you have added bottom of the services page
As with this enabled And the Eco divert off in normal
I have found that the demand shaper does not always update the times for charging slots
And also found to night that while not it a charge time slot it suddenly woke up and started to charge at full power. Have included picture. Showing the mains power which was at 0 w for a number of min before it woke up
I have set min Charge time to 300 seconds
Hope this helps you

Regards. Bill

Hi Glyn
Been playing with this last few days
I have node red turning on and off the pv Eco setting 9:00 on. 16:00 off
Few things I have noticed.
If eco is turned off by node red 16:00 and car is charging due to export. Then charge rate now is set to max and car keeps charging .
Even though time shedual is for charging to be off .

All so regarding the charger just randomly starting when eco. Is off and also solar pv divert is disabled .
This has been happening very regular my system seems to have made two entry’s in the emon feeds
Emon/openevse-1. The Base topic I set on the charger
And also emon/openevse-Bill
This is the host name I gave it on setting up the charger
I have been use Mqtt explorer
And find that the under openevse-Bill. I get a msg. Rapi. In. $ST. = 11 00. 07 00.
This is a start time that keeps coming up every time it starts to charge .
But As far as I know I don’t have anything that writes to this topic
And in the demand shaper I have it set at the moment to a timed fixed charge from 00:00 to 06:00
This seems to be changing every 30 min I have just watched as it went from 11:00 -07:00 To 11:30 -07:00
What I can’t work out at the moment is if this is being generated from the
Evse esp32 Or is it being generated by my emon pi.
Also why is the host name being used for a feed input when the rest is being logged under the Mqtt name .
The good point is it’s making me look a lot more into node red programming and the details of how this all works

Regards. Bill

The command to turn off EcoMode only changes the mode. If you want changing to stop you will also need to send a RAPI stop command $FS. You can send this via MQTT:

topic: <base-topic>/rapi/in/$FS

See: GitHub - OpenEVSE/ESP32_WiFi_V4.x: OpenEVSE V3 WiFi gateway using ESP32

Interesting, this should not happen. Could it be demand shaper starting the charge?

The emoncms HTTP input uses the hostname as the nodename. But since you have used emon/xxx as the base topic the emonPi is also logging the data via MQTT. Anything posted to the emon/xxx MQTT topic gets logged to Emocnms, see MQTT - Guide | OpenEnergyMonitor