Can not upload compiled code to OpenEVSE

I really appreciate the great work behind the OpenEVSE.
I tried to translate it to my native language (Hungarian).
First I did it in Arduino IDE, because I am quite familiar with that.
The code compiled successfully.
I tried to upload the code.
No success… Timeout. The LED on the interface blinks 3 times, and sometimes later also. But can’t upload.

The board and the communication is working, because if I send a “$” through terminal or serial monitor, I get the response $NK.
I tried many different USB-serial adaptors (Sparkfun FTDI Basic, and other cheap chinese clones, with different chipsets).
Can not upload the compiled file.

I tried to install PlatformIO, which looks promising, but it took 2 hours from my life, without success:
if I let the sentence “upload_protocol = usbasp” in the platformio.ini, then it’s looking for a programmer, which I don’t have.
If I comment out this line, then it tries communicate through my USB-serial adapter, but also time-outs.

What’s wrong, what should I try to do different?

Thanks a lot in advance,

Am I right, if I think, that I can only upload the code through the ISP port?
(No real upload, but programming)

I have spent about 14 hours, searching the answer to my problem.
Read through this community, faqs, forums, etc.
Somehow, I couldn’t find an answer.
After many “off-topic” forum readings, I got an idea about the possible cause.
Tried to investigate using that idea.
And somehow I just found this tutorial (by Google):

I wish, if this could be found from here…
Would save me years in my life and tons of my hair :wink:

I’m glad you found the answer… eventually. It’s a pity the documentation on this site isn’t better. I’m in the position of wanting to upgrade the firmware with the OpenEnergyMonitor EU version. Is it correct to assume that I need to edit the flash.bat file with the name of alternative hex file? And do I need to create a new bin file? If so, how? Thanks.

I use Arduino IDE, with downloaded ESP libs (otherwise compiler fails).
My problem was, that I thought, that the standard “upload” method can work.
But it doesn’t.
You should use an AVR-ISP “Programmer” (not a simple USB-serial cable), and the “Upload using programmer” method.

Yes, I’ve gotten hold of a USBasp programmer for the upload, thanks. Sorry, I don’t understand a lot about the hex and bin files. I assume the EEPROM file remains the same when flashing?

You will loose the EEPROM e.g. your Kwh counter will be reset