Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Broken Apps Module - Can't save settings in Apps

Tags: #<Tag:0x00007fc9b68cd138> #<Tag:0x00007fc9b68ccf58> #<Tag:0x00007fc9b68ccc10>

I’ve just changed to running EMONCMS 9.8.27 on a PC with 64Bit Debian Stretch with data restored from a Pi3,
Sadly the apps module doesn’t work, and whenever I try and select a feed in “My Solar” it pops up a box in Chrome with "ERROR: Config value cannot be array"
I get the same error in Internet Exploder, Edge and on an iPhone. Everything is on the same local network albeit I have changed the port on Apache2 so it will coexist with NGINX

Hello Kevin, could you try deleting the app in question and then adding it back in again? It sounds like an issue resulting from an older configuration version, although Im not sure.

Since the original post I deleted the MYSQL database and set it up again using a backup from my older Pi and then entering the commands from the restore script from the console. I then copied the contents of /var/www/emoncms/Modules/app over the top of the newer app module and this allowed the older version to work and remember the feeds it should use.
I just deleted this with

rm -R /var/www/emoncms/Modules/app
git clone https://github.com/emoncms/app.git
service apache2 restart

Followed by logging out and back in to emoncms.
Unfortunately I have the same error.
Copying the original older app module back has restored it.

Where does that error come from?

I thought that would have solved it, the error is being triggered on this line https://github.com/emoncms/app/blob/master/AppConfig_model.php#L95, Im not sure what’s going wrong.

Is it trying to save the feed number or the feed name? The feed I select in the old Apps module is feed 10 which is a PHPFINA called house_power. I think I select the name in the newer module?

Line 91 suggests “// Key must be lower case alphanumeric with no special char’s”

Perhaps the underscore is a problem?

Looking at “emoncms.sql” that was used to create the database I see

(10,‘house_power’,1,‘Power’,NULL,NULL,1,0,21071500,5,’’)

Does that look OK?