Community
OpenEnergyMonitor

Community

Backup EmonCMS

Tags: #<Tag:0x00007f6e13d5ab00> #<Tag:0x00007f6e13d5a970> #<Tag:0x00007f6e13d5a7b8>

Hi,

I have downloaded https://github.com/emoncms/usefulscripts into my home directory on ubuntu and wanted to backup emoncms, I have read through the readme.md file and configured the backup.php settings, tried to run it and get this error.

[email protected]:/home/usefulscripts/backup# php backup.php
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/redis.so' - /usr/lib/php5/20131226/redis.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  chdir(): No such file or directory (errno 2) in /home/usefulscripts/backup/backup.php on line 62
PHP Warning:  require(process_settings.php): failed to open stream: No such file or directory in /home/usefulscripts/backup/backup.php on line 63
PHP Fatal error:  require(): Failed opening required 'process_settings.php' (include_path='.:/usr/share/php:/usr/share/pear') in /home/usefulscripts/backup/backup.php on line 63

Not sure what i’m missing, can someone point me in the right direction?

What would be the proper procedure to backup entire emonCMS setup? in an event of a failure, I have a backup to restore to. I have tried using usefulscripts and I get the error as I mentioned above, and could not find a detailed write up for backup.

What version of Ubuntu is your emonCMS running on?

ubuntu 15.10

I’m currently using the current version of that script within dropbox-archive to backup emoncms on Raspbian Jessie, and it works faultlessly.
It doesn’t resolve your issue, but at least you know it’s not the script, and possibly a missing package in your distro?

Paul

I will look at that and adapt the script.

The error is complaining about not being able to find the redis shared sbject file (redis.so)
Is redis installed? The reason I asked about the version of Ubuntu you’re running is explained here.

Thx Bill,

I’ll check if redis is installed, doubt that it is, as far as the php5 and 16.04 ubuntu is concerned, I removed the “5” at the end of the php and all packages installed correctly, tested on latest version of emoncms.

EDIT: yes Redis is installed, I ran #redis-server and got redis 3.03 says its missing redis.so, is that a config file?