Community
OpenEnergyMonitor

OpenEnergyMonitor Community

"Apps" missing from menu

I’m not sure what happened, but my “Apps” top-menu item has disappeared. I think this happened a few weeks back too and if I recall I got it back while in the middle of moving from stable to master or v.v. I’ve just done a switch, a reboot and a browser refresh but it’s still missing.

Any ideas what I might need to do to get it back?

Thanks,

David

[edit] although it says there are local changes to the apps app I’m not aware of what they are and can happily delete anything necessary to get the menu item back.

Oddly enough I too am missing Apps top menu. I am also missing Dashboards, and DemandShaper. I think a reboot would correct it, but will wait for any feedback first. Using Local EMONCMS Version low-write 10.2.7

Hello,
I also noticed this change in the menu on the left side of the console. It must have just happened as I did a backup the other day and today the “backup” selection was missing. I did a full update and a reboot but with no change. The feeds seem to be working as they should but when I attempt to graph one I get the following message:

EmonCMS Error

Message: ReferenceError: Can’t find variable: menu
Route: Modules/graph/graph.js?v=12
Line: 237
Column: 13

My setup:

Modules: Administration | App v2.3.0 | Backup v2.2.7 | EmonHub Config v2.1.1 | Dashboard v2.1.1 | DemandShaper v2.1.3 | Device v2.0.10 | EventProcesses | Feed | Graph v2.1.0 | Input | Postprocess v2.1.5 | CoreProcess | Schedule | Network Setup v1.0.2 | sync | Time | User | Visualisation | WiFi v2.1.0

House power monitoring system (USA) with the following:
RPI 3 loaded with flashed OEM software on 32 GB SD (latest updates)
emonTXV3 + AC/AC power, RFM69Pi_433 (purchased July 2017)
2 x SCT023R (200A:50MA) on 220 mains (North America 2 x 110)
emonTH V2 (purchased Oct 2017)
--------
weewx weather station (VP2) on Node 0

Any idea what may be causing this? Thanks in advance.

Bob

I just did a reboot, and still menu items missing.
I noticed I lost power 3 days ago, I wonder if my configuration
looks for an update during startup.?

I have 2 identical local EmonCMS’s running. Here is a screenshot of them side by side.
You can see side bar on top menu items missing. Although it is still collecting data.

I too get an error when I try to graph an input, I get “EmonCMS Error: menu is not defined Modules/graph/graph.js?v=12”

I will investigate log files next.
Graph Module Missing

As far as I’m aware, emonCMS always, automatically, updates itself on a re-start. I’m running a test version of the Atmel front-end software, and that’s been overwritten back to the default many times by that mechanism.

After an extensive search of the forum I found something that seems to have fixed the problem.
“cd /var/www/emoncms && git pull”
This was recommended by Paul several years back to someone who was in the same sort of situation. I am not a programmer but assume that this refreshes things after an update which must not have completed properly. I see that it brought things up to the latest “stable” release 10.5.6.
It might be worthwhile for someone with the know-how to explain what must have happened here. It did happen after a “full update” from the admin page.
Many thanks.
Bob

Thanks much Bob for finding the solution.

Just as you found that running the follwoing command corrected my problem also: cd /var/www/emoncms && git pull.

I appreciate you posting the solution.

I have the same problem. One moment it was there and then not. I have tried the ‘git pull’ with no luck.

Any ideas?

Hello @maximundo what kind of system do you have? is it a Pi based emonSD setup or a self-install emoncms system?

Perhaps try:

cd /var/www/emoncms
git pull
cd /var/www/emoncms/Modules/app
git pull

Hi @TrystanLea

The git pull in the /Modules/app folder highlighted customisation I made for the mysolarpvbattery app. I removed my change and the git pull worked. The apps are back!

Thank you.

Max

1 Like

I got mine back with a git pull in /Modules/app without having to revert anything I had done.

David