Administration not available in Setup


I finish to update , however Administration item is not available in Setup.
I can access it directly with the URL only.
How can I solve this? Thanks.

I have:

Emoncms Version 9.7.9 | 2017.01.05
Modules admin app backup config dashboard device eventp feed graph input nodes openbem process schedule time user vis wifi

Have you tried logging out then logging in again?

I already reboot Raspberry, my browser and my computer.

OK. It was something I remembered from an older version of emonCMS where you couldn’t see the admin menu until you logged out then logged back in again.

After this update I had 2 problemas… this Administration menu, and NODES. All my nodes just gone… are not appearing. But I have all data into INPUT and FEEDS. :dizzy_face:


Have you tried what Bill has suggested??

Log out of emoncms, and log back in again.


Yes, I did. And also all I wrote before.
Nothing yet.

Could you post a screen shot?

What browser are you using?

I am using: MacOS X 10.12.3… Safari 10, Firefox 49, Chrome 55. All them the same problem.

Now I saw that my Power to kWh feed also lost data. It is negative… :scream:

This is very strange I’ve just tested on a number of different emonPi’s with a number of different browsers (Chrome 53, firefox ) and am unable to replicate the issue.

Can you access the admin page if you browse to ?

  • Was the admin menu visible previously?
  • Did it disappear after an update?
  • Have you made any changes to the standard emonSD?

Could you post the ‘emonpiupdate.log’ this can be downloaded from the admin page, you will need to access via the URL!

Not sure what’s going on with your power feed. Best also include 'emoncms.log and ‘emonhub.log’ so we can try and work out what’s happened.

  1. Yes, I can access admin page with direct url.
  2. Yes, menu were visible before update.
  3. No, I use standard emonSD.
  4. Yes, added update LOG file.

emonpiupdate.txt (6.1 KB)

EMONHUB.log has only many:
2017-02-01 23:01:04,223 INFO MainThread EmonHub emonHub ‘emon-pi’ variant v1.2
2017-02-01 23:01:04,225 INFO MainThread Opening hub…

EMONCMS.log blank.

Ah, looking at your logfile it seems your running the older emonSD-17Jun2015 emonSD. This is probably why I can’t recreate the issue.

I would highly recommend updating to the latest Nov 16 emonSD… The backup module (http://192.168.1…11/emoncms/backup) can be used to migrate all your data.

However this is not the cause of the issue, the update should work ok on the older image. Looking at your screen grab it looks like you might have manually updated to emoncms V9? Is this true?

Looking at the update log I can see lots of files (emonhub & emoncms) which have been manually modified, these modifications will stop the system from pulling in any new updates.

I think the cause for the admin menu missing is the device module is installed. This is not a module that is installed by the standard on the emonSD, did you install this module? If your not using the device module could you try removing it by deleting the folder /var/www/emoncms/Module/device/. The device module has taken the place of the admin menu in the menu. The device module is an older unmaintained module and does not have the correct menu manifest config to work properly with Emoncms V9


SOLVED!! Just remove device module and Administration came back.
Thanx a lot.

** Can I post “blank nodes” and “negative Power to kwh”? Any idea what could be doing this?