Community
OpenEnergyMonitor

Community

Admin Authentication Required on new LAMP stack build

Hi There.

I have copied the install instructions from this post ( which I assume includes the latest stable version " as referenced " in the doc ) https://github.com/emoncms/emoncms/blob/master/docs/SharedLinuxHostingInstall.md

The installation went very smoothly bar the fact that I cannot login. I get a message "authentication required " - please see screenshot

Any guidance to resolve will be greatly appreciated.
Regards
Wayne

Hello @Wayne, have you connected to an old database that might have an existing user in place? You should expect to see a register link on that page, there’s no admin login.

Hi Trystan

It was a brand new build. I was presented with a register page which I completed and it then went to this page.

In phpmyadmin I can see myself as admin user . I must also add that i never received any email to verify my registration ! I have however tried to manipulate this by changing the “0” in the “email_verified” field to “1” but this doesn’t work. Additionally the “verification_key” field remains blank.

Please let me know how i should proceed?

So use those credentials to log in. The first user created is the ‘administrator’ account.

Expected behaviour, that isn’t available on ‘self’ builds (AFAIK).

Hi Brian - thanks for the input. I have most definitely tried with the username that is logged as admin in the DB, its the only one i have been trying…

I have attached a screenshot of the PHPMyAdmin User table and as one can see there is 1 data entry in the table. The “verification_field” is however empty and i assume this is why i cannot login.

Thinking out aloud , should i delete the entry entirely and try and register again ? or are there any suggestions on what data to insert in the “verification_field” ? Perhaps even try a fresh DB install?

Trystan, Brian - any help please.

Thanks @Wayne it looks like you already have a user there? You could try deleting that row if you want?

@TrystanLea I deleted the DB line and went back to the URL, was presented with a registration form - registered and same happens. Safe to say this doesn’t fix the issue.

Is it not the “verification_key” which should contain a value?? it is blank again.

This is odd.

Are you using the username or the email to try and log back in?

The Username Brian. I am using “Wayne” & the password I registered with. ( see screenshot ). The login form is definitely cross-checking the DB because if I try with a random username it says “User name does not exist”. If I try with “Wayne” it says “Authentification required”. Does anyone know what field is supposed to be in the “verification_key” - i’m almost certain this blank field is my issue?

I don’t think it it used but @TrystanLea will know definitively.

If I use the wrong password I get
image

It seems you go back to the logon screen? Looks like something with the server setup rather than the authentication mechanism.

exactly right Brian. If i enter the incorrect password i too get the same error ( see attached ). But if i enter all the correct details i just loop back to the logon screen…

@TrystanLea - help please ;-(

Yes so It may be the redirects are not working. It isn’t an authentication issue as such.

However I do not get that ‘Authentication Required’ message at the bottom of the logon dialogue.

Tx Brian. Lets wait for Trystan to advise

Hi @TrystanLea, @borpin,

I have spent a few hours trying to resolve my issue , but to no avail. I tried many things and then realised it may be because a “wordpress” install was in the /Public_html directory. I then decided to install on a fresh domain with no other content. I now receive a different error : “The requested URL /emoncms was not found on this server”. I found similar posts on this issue but Ubuntu related - i am running on Centos 7.7 , Apache 2.4.41, Nginx 1.16.1 - PHP build 7.0 on this domain.

Appreciate any assistance - suggestions?

It could well be the .htaccess in the root folder that is the issue.

@borpin please see .htaccess in /public_html root. What changes would i need to make to this?

No idea if I am honest - it is just where I expect the issue to lie ultimately. I have had this sort of issue before with Wordpress on shared hosting (it is much better now than it was).

I think there is a php_info.php file in the emoncms folder. Can you access that URL directly?

Yip the file is there Brian but i cannot access it from browser - same 404 error…??

Something not right with the host setup. You will have to ask them.

Brian - i was an idiot. After setting up the fresh domain i forgot to update A records in DNS. Thats sorted now , and i am again back to my frustrating place of not being able to login… Very frustrating. I am admin in the DB ( registration seemed to work well ) but cannot login … @TrystanLea - any help please?