Community
OpenEnergyMonitor

Community

406 Not Acceptable. URI not acceptable. Phpmyadmin cannot respond to ""

Tags: #<Tag:0x00007fc92516f440>

Trying to install phpmyadmin on my Pi running low-write 10.1.11.
I did sudo apt-get install phpmyadmin and chose default options during installation, except I did NOT opt for default configuration with dbconfig-common since I assume there’s already a database installed. Then I tried going to http://192.168.1.82/phpmyadmin but get the error Phpmyadmin cannot respond to "". I suspect I need to configure phpmyadmin to emon databases but not sure how to proceed. Any suggestions?

Hi
I just installed phpmyadmin on a pi running the latest os. I used the default options and even if I have already a database running, I defined a password. Then I tried to connect with that password and the root username but that did not work. So, I looked in the settings file of my emoncms install and found out the username and password of the database. That finally worked.
One more thing: there is a recurrent php error coming from the phpmyadmin app when you try to look at the emoncms database. This is a known issue. Search the internet for that error. There is a topic explaining what you need to do or wait for the next release.

By the way, I used the set of scripts that installed everything automatically ( emoncms, mysql, mqtt, apache, etc.). That worked well. Great work.

Sorry, I can’t help you for your specific problem.
Walter