OpenEnergyMonitor Community

Wifi config on Pi Zero using emonSD

Hi, I’ve got a pi zero and a RPIZCT4V3T1. I’ve installed the
emonSD-26Oct17 image, but as a noob I’m struggling to get wifi to connect. I’ve configured what I thought was the correct wpa_supplicant.config file with something like…


but still no joy. Can someone point me in the right direction…

Thanks Andy

How exactly are you configuring the wifi for the Zero?

AFAIK it cannot be done on a emonSD image without using another Pi with Ethernet or possibly with a micro-usb Ethernet adapter.

The official Pi way of doing it is to add a wpa_supplicant file to the boot partition on another PC before inserting the SD in the Pi zero and booting, the Pi Zero then finds the file on the boot partition and configures the wifi during setup. The emonSD is read-only at boot up and that wifi configuration facility doesn’t work.

see the Using wpa_supplicant.conf file on the emonSD boot partition thread and possibly the Raspberry Pi Zero W SD image thread too.

I’ll have to try one of the methods mentioned in the links… unless there is a new image due out soon with pi zero support…(wishful thinking)

Cheers Andy.

It essentially boils down to running these 3 lines on a Pi that has Ethernet (running your new emonSD image)

sudo mv /home/pi/data/wpa_supplicant.conf /boot/wifi.conf
sudo ln -s /boot/wifi.conf /home/pi/data/wpa_supplicant.conf

Then the wifi settings are exposed on the /boot partition for editing on pretty much any PC in a file called wifi.conf. So if at anytime in the future you change your SSID or password (without editing the Pi Zero’s wifi settings first), you can just whip out the SDcard, edit it on a PC and refit, job done.

Yes it would be nice to see this as part of the standard emonSD image to make use with a Pi Zero or Pi A+ easier, perhaps @glyn.hudson will consider it.

[edit - also check out the Powering down a headless Pi with no network connection thread that was written as result of mentioning how to handle a change of wifi SSID or password above]

1 Like

the ln link command and editing it in windows worked great. Now to get it to work on my RPIZCT4V3T1.

Thanks Andy

1 Like