Upgrading OpenEVSE / EmonEVSE Controller Firmware using ISP programmer

Now that I have the OpenEVSE module on the bench, I have again tried to program it. I followed your advice, Jeremy, to try and power the module from the Polulu progammer, following the instructions to enable the 5V output from the programmer, in the documentation you pointed me at, John.

Reading those docs, I was dubious that the programmer had enough oomph to power the module, in particular the capacitance it can cope with on Vcc is pretty small. This turned out to be the case, as the programmer just gave up when trying to power the target directly. I think the 5V output from the programmer is only really intended to power a target with not much more than the processor chip itself. Maybe the programmer you have, Jeremy, has more oomph than this one.

So taking your advice, Jeremy, that it would be ok to power the OpenEVSE module with 5V inserted on the ISP connector, and since the 5V and GND on the FTDI interface connector are common with those on the ISP connector, I inserted 5V DC from a separate power supply into that connector.

The Polulu programmer now detected the target Vcc just fine, but I still get the same error from avrdude when trying to read or write anything from the Atmega chip.

From the docs that John pointed me at, I was able to download the programmer status and setup utility. This gives me the additional info that, after attempting to connect to the target, I have the error message “The SPI command for entering programming mode was sent, but the expected response from the target was not received”.

This tends to confirm my suspicion that I have managed to disable ISP programming by corrupting the “fuse” value that enables this. I have been advised that this can only be fixed with HVP and that cannot be done with the chip in circuit. Does that sound correct to you, Jeremy? I do understand that you have really only been involved in the Wi-Fi module.

In the absence of any help and support from the actual hardware designer or firmware author of the OpenEVSE module, I think my next step has to be to replace the Atmega328P chip with a new blank one, unless anyone can suggest anything else I can try? (A friend from MERG has offered to send me a blank chip, as they seem to be out of stock at all suppliers).

Thanks,

Pete

Hi,

i have the same Polulu programmer.
Can you tell me which windows drivers you used?

I don’t understand if i need to use the same drivers as explained in the guide ( libusb-win32), or the one delivered with Polulu software.

Also, should i use the programming port ?

image

Regards

Hi,

I just used the included drivers but did not bother with the TTL one as was not using that side of the programmer. Did not use the programing port as I think this was to change how the device worked and as it was OK using the default settings was happy with that.

John

Hi,

upgrade done.
Thanks so much for your help.
Lots of help on this forum. (commands, plans etc…)
Regards from france

1 Like

Glad we were of help :slight_smile: