Target doesn’t answer

I tried the TI part as the complete boards were not available. Tried to test, but so far have not been able to upload the program due to “target doesn’t answer”.

That part won’t prevent you from programming the attiny, so there is probably a solder joint missing or bridged

Thanks for confirming it’s not causing the programming issue. Once that’s sorted will be happy to report on the success or failure of the part substitution.

Unfortunately, 10 of 10 boards tested fail to connect. No visible problems with the pin soldering, but who knows. I’m too blind and inexperienced with SMT to judge for sure.

What programmer are you using? Does the greed led on the module flash when you attempt to program?

Chinese USBASP from Amazon. Had to hack the 10-pin cable into the 6-pin pinout (mentioned here: Can't flash cell modules... Platform IO/UsbAsp [upload] Error 1 - #3 by Jon_Coop) then everything worked. Won’t have micros for the controllers until Friday, so can’t fully test until the weekend.