Symlinking services in Jessie doesn't work

No, it gives me the error either way, i.e. whether the line is there or not.

Made sure that didn’t happen.

1 Like

That exact same error, or a different lvalue error? If you’re getting that error without the Type= line, something else is definitely going on!

Same error.
The weird part is when I move the file to the /etc/systemd/system directory the error goes away.

Ok, can you clarify exactly what you’ve done after you put the file in /lib/systemd/system?

In /lib… or /etc… ?

The issue of the lvalue error occurs when you put the service unit into /lib right? If so, then what did you do after you put the file in there?

I do use emonBase, but funnily enough I upgraded to the RFM69 receiver board because I wanted RSSI values. Good to know about the emonSD behaviour though.

It’s not just about the base. For instance, the emonHub node decoder assumes your nodes conform to a particular ID range set by DIP switches, whereas mine do not. Other things like firmware have been forgotten about; for example the only emonTH 1.x firmware in Git is for 1.5 boards, as it includes JeeLib and all of the DIP switch logic. As this last version of firmware was the most optimised, I have ‘ported’ it back to my 1.4 boards by reverting to RFu_JeeLib and pulling out the DIP switch logic, but it’s yet another ‘non-standard’ part.

So really it’s about the system as a whole and the amount of tweaks that become necessary during major emoncms releases.

Anyways, appreciate your advice - thanks.

Enabled it, then checked the status to see if it was running.
It was running, but that’s when I noticed the error. Didn’t do anything else.

Aha! Thanks Greebo. Reading through that PR fills in all the gaps and confirms the behaviour I’ve been seeing.

Slightly frustrating though, because the Pull Request recommendation to have ‘special instructions’ for Jessie users never actually made it to the service install notes - if they had, we wouldn’t have this thread :wink:

Thanks again,


1 Like

Do you mean you ran the following?

sudo systemctl enable hplt-pwr
systemctl status hplt-pwr

If so, after doing that is there a symlink in /etc/systemd/system pointing to the file in /lib/systemd/system?

Yes, those are the commands I ran. (with sudo prefixed to the status command as well)
It put the symlink in /etc/systemd/system/

Can you post the full output of the status command when the file is in /lib/systemd/system?

Since it’s working, I’m thinking it’s best not to mess with it.
I sure as heck didn’t mean to hijack the thread. That wasn’t intended.
I’m going to let it ride as is.

Thanks for taking time to troubleshoot it. thumbsup