PV divert and BMW i3

Hello all.

I am eventually able to use the PV divert feature on my OpenEVSE.
I had a tiny MQTT issue (had to reboot the wifi to get it to work) but the OpenEVSE now gets the updates and is able to modulate the charge.

However, I have an issue that seems specific to the i3.

When OpenEVSE lowers the charge (under 6A, even going to zero amp), instead of going in pause, the i3 goes into error.
It says the charge was interrupted and stays in this error mode until I manually disconnect/reconnect the charging cable.

I encountered the issue a couple of time when I was not using PV divert but modulating the charge manually: going down to 6A ended with the same “interrupted charge issue”.

Any idea of a specific parameter to deal with this?

Oops, didn’t want to delete this.
Here it is again

Definitively seems to be an i3 issue, because other “pausing chargers” encounter the same problem. Could be linked to the DC-DC converter way of operating.

Yessterday was a real PITA.
Sunny with nice blue sky, lot of wind with few thick white clouds.
Each time a cloud blocks the sun light, the i3 goes in error.
Definitively can’t leave the house and hope the i3 would be charged when back.

After 4 unplug-replug, I eventually stopped the eco mode (PV divert) and charged at 24 amps flat.

Hi David,

I have had never had this problem with either of my i3’s we have a 2016 and 2021 model.

What version of the firmware are you running? mine are:

In the config setting what do you have for pause status?

1 Like

Hi Paul

Mine is a 2018 i3 (94Ah with Rex)

OpenEVSE 8.2.2.EU
OpenEVSE wifi 4.2.2

Pause status is same as yours but service level was forced in “Level 2”.
I’ve put it in Auto and will try again tomorrow.

No cloud today, it worked flawlessly.


Clouds today but the “pause” is working.
I plugged it in at 16:47 and it paused itself at 17:27.

Maybe it’s about the “pausing speed”?
I mean maybe it worked today because it did not went from 20+ amps to less than 6 amps in a couple of seconds but went down gradually?

Could it be that going down gradually, the i3 doesn’t consider the drop as “insufficient grid power” but “going into sleep mode”?

Even better, now the cloud is gone, charging went out of pause…

Failed again today, when starting.

Another cause could be the start level: if I do not use PV divert but manual charge and set the power to 6 amps, the car fails. If checked at this precise moment, only 5 amps are sent to (taken by?) the car.

It’s the same issue whatever power is manually chosen, even forcing to 32 amps shows only 31 amps sent to the car.

Would it be possible to change the minimum sent to the car to 7 amps?