Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Platform IO V5 "Upload file system image" option moved

I have some problems upoading to the esp8266. I followed the instruction video unto 6:00. Unfortunately in visual studio there is no “upload file system image” on the menu.


When i restart the esp8266 i can connect to it as AP with SSID “DIY_BMS_CONTROLLER” but i can’t open any webpage. What did i do wrong?

It seems some platformio update changed this. However, you don’t seem to have the “Platform” thing to look into like I do (see below), so I don’t know where you can find it.

Go to http://192.168.4.1
The browser might be eager to search the web for 192.168.4.1, so beat it into submission by explicitly typing “http://192.168.4.1

Sure, i tried that. Thats the problem, its not working…
My Browser tries to open a page called http://192.168.4.1/softap.htm. (HTTP ERROR 500)

Oh, then that part is good.

It is failing because you have not found the “upload filesystem image” button. I remember the button disappearing on me right after platformio upgraded, and I managed to fiddle and get it to appear as shown on my screen shot. Try quitting VS, and reopening things. Open the platformio.ini file. Hit it with a hammer?

Hello, looks like the platformio 5 has changed the layout, this issue also mentioned the problem [https://community.platformio.org/t/cant-find-upload-fs-in-platformio-tasks-after-update-to-2-0-0-or-2-0-1/15910/2]

The option is still there just need to expand “platform” and then upload filesystem image.

image

I solved it by doing this:


I clicked all 4 menu points under misc…
Don’t know which one worked haha suddenly there was “Platform”
Thanks for helping anyways…

192.168.4.1 “Can’t handle this request right now” ? Has anyone seen this before?

[edit]
It’s not much fun when you download the ‘newest’ zip file for the controller code, open the workspace included in the zip file, then click on platformio.ini–click on the alien head–scroll down to envesp8266_d1minipro–(even though it is not the pro, very confusing)–once loaded, click on upload-- then look for the ‘upload file system image’ and it is NOT there. NOT fun. So if it’s been a while and I forget, or get confused as to which one needed the upload file system image, the controller or the module, you would think that it’d be there and I’d see it and upload it. So now I open the module code the same way and it’s not there either, so now what do I do watch stuarts video -again-?
I’m just saying, it should always be there, either cloning the whole bundle, downloading the zip file and opening the workspace, or just opening the folder and doing it that way. But it’s not there.
I know I’m forgetting/missing something and I’m sorry windows 10 and vscode with platformio extension. I haven’t had a problem until now.

Edit the edit by MOD to make the edit clearer!

found it. Geez what a hassle

PlatformIO has moved some of the options around in version 5, so the video is a little out of date.

We discussed this on this post… Platform IO V5 "Upload file system image" option moved

Thanks for responding.
I started with v3 and it worked for me. v4 seems scattered kind of all over the place.
Also, in v3, you received the success screen after you connect to your network. v4 you get nothing.
But that’s off topic
Thanks again

Agree, the project grew rapidly and the code and hardware files are not organised as well as they could be.

The problem now, is that a lot of videos and instructions mention the files as they are now, so if I change it, all those become obsolete.

Maybe a ‘Changes in procedure’ chat.
Maybe version 4.0.0, small changes would be 4.0.1, larger changes 4.1.0. The original is what I’m working with, the 1W resistors. I see the small changes in the circuit design basically to save money and time for folks, Personally I don’t think it was necessary to complicate this project that way. The saving time/money version should have been given an alternate name, not an updated name like v4S.1.1 or v4J.0.3. That way the original version 4 is not confused with the JLC version. So when there is an update to the main structure of v4, it can be spread out among the other versions (if necessary).
When I see this project moving from v3 to v4 I expect a pretty big change. When I see v4 updated to v4.1 I expect to see a moderate change. When it keeps changing (v4.2, v4.21 etc.) I’m beginning to get lost. I expect to see relatively moderate to major changes in the circuit design, but that is not the case so I end up somewhat confused.

What you’ve done here is awesome! Don’t think it’s forgotten. Myself and many others would agree this project you’ve created is quite amazing.

1 Like

I havent been on here for a long time due to covid and feel sorry to ask the forums advise again but i am still having problems programing my DiyBms controller.
The problem seems to be that the compile hangs forever ie left it over night. I have now three different D1 mini pro’s esp8266 but none of them i can program.
I am guessing VSCode is ok as i have managed to program the cell modules v4.21 without any problems.
I have tried to upload the code didnt work and also just tried building the code also, but still nothing.
I have followed step by step Sturat’s programing guide but i am having now luck using VSCode also i have downloaded the code again just to make sure its not got currupted.
I am sure i must be doing something silly so any help would be very much appresiated

.

I think you need to also upload the file system. It’s located under Platformio
below advanced and network development.

Good Morning Fred,
Oh ok still new to this but learning wasnt sure if you ment the top half of the screen or not but added it as thought couldnt do any harm, I have looked under all the tabs within Platformio but dont see a advanced or network develoment tab?
I am using version VSCODE 1.49.3?
Cheers

Take a look at this

Just edited my post with the Uploaded filesystem image
Thank You for your help Sturat its much appresiated.
Mike

2 Likes

I dont know if this is the place for it, but when i open platform io,open the workspace, choose the d1minipro i dont have the platform pulldown menu?
I am able to"clean" but all other options result in error termination with error code 1?

What can I be doing wrong?
Thanks in anticipation

It’s likely that platform Io isn’t working right. Perhaps an update or reboot may help?

I did reboots, fresh install, with reboot after deleting and cleaning up folders. And also tested on a different pc, same story.
With and without wemos attached, i see “platform” or possibilty to choose upload file system image…
Perhaps i can try on a different machine tomorrow