Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Pi ZERO running emoncms

Just installed netdata.

Wow, LOTS of downloading and compiling. The machine I installed it on is has an Intel I3
processor running at ~2GHz. Installation took about 5 minutes. So probably a bit longer on a RPi.

TONS of info though. Pretty slick!

That’s not so appealing!!! I haven’t tried installing it yet . .

Here’s a screenshot of it in operaton:

A partial screenshot, really, as there is MUCH more data below that shown. i.e. many screens.

I just started a install on a headless RPi and it didn’t start off so well!

[email protected]:~ $ date
Tue  2 Apr 13:51:32 BST 2019
[email protected]:~ $ sudo bash <(curl -Ss https://my-netdata.io/kickstart.sh) && date
bash: /dev/fd/63: No such file or directory
[email protected]:~ $ curl: (23) Failed writing body (314 != 1369)

a (very) quick search on that error turned up this

so the command line given by the netdata readme needs changing for headless over ssh. I’ll come back to it later as I should be doing other stuff.

There are live demo sites at https://my-netdata.io/#demosites

FWIW, I ran it with:

bash <(curl -Ss https://my-netdata.io/kickstart.sh)

Here’s a file with the screen activity during the install, in case you’re curious…
netdata_install.txt (171.8 KB)

Depends on your OS I guess. DietPi must download binaries, took less than a minute… :laughing: :laughing: :laughing: :laughing: :laughing:

That must be the case. The machine I installed it on is running Debian Stretch.

thumbsup

Really I think the only issue is the setting up of the database and particularly the username and password. I think if you used the same as the standard Emoncms installation it would be better. That is: Username = emoncms and Password: emonpiemoncmsmysql2016

Your instructions were very useful. Thank you!

Ah, this is because the emonpi introduced a default database password. My guide was based on the LinuxInstall Guide where you created your own password. Thanks for the feedback. I may just make it a bit more generic rather than plump for the default password.

Cheers.

I decided to have another go at this. I installed the latest Buster and then used the EmonScript. This all seemed to go well. I didn’t modify any of the settings within the EmonScript (probably where the problems started). After all the installations finished the RPi needed to reboot. I couldn’t access it via Ethernet > USB using SSH any more. I removed the microSD card and looked at some of the files, eventually I looked at the /boot/config.txt and found the problem. The line “arm_freq = 1200”. I doubt that any RPi Zero are going to operate at this frequency. I commented out this line and all seems good afterwards.

1 Like

Yes there is an open issue on GitHub @TrystanLea.