OpenEnergyMonitor Community

OpenEVSE DIY Tethered 3-phase

How to use the contactor relay for 3 phase 440 v supply using the Open EVSE kit

Is this thread any help?

Yes, the OpenEVSE can be used with a 3-phase contactor

  • Connect the openevse controller between L1 > N (240V)
  • Connect L1-L3 + N through the GFCI CT
  • Connect L1-L3 + N through the 3-phase contactor
  • Connect the power CT to L1

The OpenEVSE current reading will measure the current in one of the phases. You would need to modify the
display to correctly calculate the kWh supplied.

See photo of a 3-phase openevse setup:

Three phase contactor can be purchased from:


Thanks Sir

Just one question what is the actually use of 3 phase input if we are
connecting the controller between single phase only …!!

Vinay Jakkal

The three-phases will be used to charge the EV e.g 16A 3-phase = 11.5kW, 32A 3-phase = 22kW. Obviously the EV will need to be able to support 3-phase charging e.g. BMW i3, Tesla.

How accurate the current readings will be if we measured only one phase?

When charging an EV the thee-phases will be balanced i.e the on-board charger will draw the same current from each phase, therefore the measurement will be accurate. Although if billing grade energy reading is required It would be best to also install a 3-phase utility meter inline.

Thank you!

    I'm working on a new controller board based on openEvse.

    The board will only support an alternating current relay and will be suitable for mode 3 installations.

    Do you think that three current sensor circuit one for each phases  will be a good solution?

    I need an billing grade energy reading.

Yes, if you have available inputs on your controller board I would recomend adding the option for 3 x CT inputs. Also a AC voltage monitoring circuit would be a good addition to monitor the AC voltage.

True, maybe i can use the relay sense input line.

To connect a type 2 Menekes 3 phase tethered to OpenEVSE, must I install any resistance in any place (in he plug).
If yes can you put a connexion scheme?

No cable modifications should be made. Only the EmonEVSE supports three-phase, the EmonEVSE will automatically detect the current rating of the attached non-tethered cable and will set the max current accordingly. See:

How the system know the maximum capacity of the cable?

Has the cable any electronics to inform about that?

I’m doing an OpenEVSE tethered 3 phase following this

Jordi Llovera

Yes, all T2 non-tethered cables have a resistor between PP and GND which inform the EVSE of the rating of the cable. See my link posted above for more details.

This resistor is located in the EVSE end of the cable and is only used in non-tethered EVSE’s since in the case of a tethered EVSE the cable connected is always the same therefore the max current rating can just be set once at installation. In the case of non-tethered units like our EmonEVSE any cable of any rating could be connected at anytime. The PP wire is not used for non-tethered units.

Hi Glynn

I installed again the EVSE you sent and it doesn’t work

Please I need your help !!!

I have an:


3 phase 400V

Tethered Menekes

Firmware actualized to 3 phases: openevse-3ph.hex

I’ve disabled GFCI because I’ve a 30mA differential

I connect to the car and it doesn’t charge.

The display says “Connected” but it doesn’t work.

The 3 phase relay doesn’t connect because there is no tension between in coil.

I tried with a BMW i3 and Renault ZOE with the same result.

Can you tell me if my DIAGRAM is correct?

I verified that the ground cable is really connected to my house’s ground with 0 Ohms of resistance

Please can you answer all this questions?

1.- The violet cables as a Coil test are connected between L1 and Neutral. (your diagram is between L1 and L2, then 400V, wich one is correct?

2.- I connected PP and CP. Is this correct?

3.- Why it doesn’t charge?

4.- can OPENEVSE charge with tethered cable ?

5.- must I put any resistor between PP and ground to say to EVSE my car is plugged as an un-tethered (I don’t have an EMON EVSE but an OPEN EVSE)?

6.- Is my firmware, useful for that?

Thanks for your answer

Kind regards

Oh dear, there must be some issue with your installation. I tested the unit extensively

These pins are stuck contact detection and should go to the output of the relay L1 and neutral. which diagram are you referring to.

No need to connect PP on a tethered system

Good question, it was working when I tested it! Please share some more photos of your setup so I can better understand how you have connected it.

The standard OpenEVSE kit which you have is for a Tethered Cable. Using a non-thered cable requires different firmware. The OpenEVSE kit does not have a non-tethered type two socket. I would recommend using an EmonEVSE three-phase if you want non-tethered:

All untethered cables have a resistor ready built in. If your running EmonEVSE firmware then this resistor is require to turn on. Are you trying to build an un-tethered system? Please share photos so I can understand.

What firmware are you running?

The device is still not charging the vehicle, the main board is not supplying the required voltage to the contractor coil.

Please find below a summary of the current situation of the issue:

I bought an OpenEVSE charger, to install tethered and triphasic.

I changed the original monophase contactor by Schneider 3 phase + N and 240V coil.

My firmware is version 5.1.0.EU openevse-3ph.hex from may 2019

I disabled GFI test because I’ve an RCD.

I’m using this EV car plug IEC 62196-2,searchweb201602_1_10065_10068_319_10059_10884_317_10887_10696_321_322_10084_453_10083_454_10103_10618_10307_537_536_10902,searchweb201603_57,ppcSwitch_0&algo_expid=b5029c05-a5d8-40c5-9972-8a5fc75e5e39-17&algo_pvid=b5029c05-a5d8-40c5-9972-8a5fc75e5e39&transAbTest=ae803_3

I connected CP and PP wires from the EV plug to the main board.

There is no resistor installed between Ground and PP.

The Wifi connection works OK (version 2.7.7.)

I used the following connexion diagram

When I connect the charger to the grid the display says “READY”

When I connect the car (BMW i3) it says “CONNECTED L2:16A” but it doesn’t charge.

I checked all these points without any result:

  • No AC power to AC_Input
  • LCD 4-pin connector is reversed
  • Short on output will put power supply into protection mode
  • Fuses next to AC_Input on the board blown (labeled “bel”)
  • Power Supply module has failed
  • Supply voltage measured at AC INPUT is 240V (normal).

  • I have tried to invert the connection between the AC INPUT 1 and the AC INPUT 2, but the charger is still not charging.

  • I tested the ground connexion in all the points on the diagram to check continuity (all OK).

  • I checked the supply voltage for the display = 5 V.

  • I measured the voltage between lines and are from 398 V to 405 V, and between Lines and neutral are from 229 V to 231 V (normal).

  • I checked the 2 fuses labelled “bel” in the main board and they are OK.

  • The contactor does not click and the coil doesn’t receive any Voltage from the charger. If I put 240V directly to the coil, the contactor clicks correctly.

  • I checked output tension for the 240 V coil and 5 V coil. All of them are at 0 V.

I checked the CP voltage in differents status and the results are:

  • CP "not connected" = 11.58 V
  • CP "EV Connected" = -4.56V
  • CP "Sleeping" / "Pause" and "Connected physically" = 8.95 V

Do you have any idea why the main board is not sending the required voltage to the coil?

Please, may you advise me on what else I can check? I don’t understand why the device was working when you tested it yourself and I don’t manage to make it work at home. I am following every step of the guide but it never charged my vehicle, even if it every part seems to be working. I even tried it with a Renault Zoe and got the same negative result.

I have the kit since one year at home and I really would like to make it work but I need your support.

Thank you very much for coming back to me,

Kind regards,


Sorry to hear your still having trouble.

The PP wire is not required for tethered installation. Try disconnecting it.

If your still having issues, I recommend getting a EV simulator board to allow you to test each state individually:

The controller was definitely working when it was shipped.

Hy Glyn
I tried all that yet.

I disconnected PP wire and nothing happen

I tried too with a simulator with 882 ohms and diode. the disply says “error ventilation required” in red

can be the firmware?

kind regards


It would be a good idea to test with the standard OpenEVSE firmware non three-phase: