New clean build in a 2016 Pi 3B unit - Services won't start (10Nov22 image)

Hi Lee

The Raspberry Pis were both purchased from the OpenEnergy store with software installed back around 2015 I think.

Yes I have tried the commands suggested – no joy





But, John says:

There’s always the chance the two new cards are not good.
But the odds on that seem to suggest other issues are at play here.

Given the age of both emonPis, opening them, reseating the daughtercard
on the GPIO connector and inspecting the boards for cold solder joints
wouldn’t be a bad idea.

Hi Bill thanks for suggestions
Ihave taken both apart and checked for dry joints etc… - All good I believe

Just tried a 3rd card - same result


More Information
Is it possible that my hardware will not run this latest Image ??
On the pc board it says emonPi v1.6 Jun2015.
Is there some code that needs to be run to transition this board to run the latest Image ??
I have found a 24Jul2020 image and it appears to work

When you say no joy, what exactly happens when you type those commands?

Prior to the notice in the last day or few about the ‘new’ emonPi, which is on the way (AVR-DB: emonTx V4, new hardware in progress - #298 by TrystanLea), V1.6 was the latest version. It also depends on the Raspberry Pi itself, as far as I know, every version after 2B works, I’m not sure of anything before this.

How are you writing the image to the card? Problems have been reported with Raspberry Pi Imager. (Login Problems - #17 by RichardOwen)
Does the checksum on the download match?
(Long shots, I know)

Unlikely, I don’t have an EmonPi, I have an RFM69Pi which is an older but similar idea without the screen attached to a Pi2. It’s running the latest image EmonCMS/EmonSD image with lots of further updates pulled from GitHub.

Hi Lee
When I put the commands in they were accepted without error but nothing had appeared to change

Hi Robert
I was more focused on the Raspberry Pi imager verifying the image on the SD card.

The results are below
I:\EmonPi>certutil -hashfile MD5
MD5 hash of
CertUtil: -hashfile command completed successfully.

I:\EmonPi\emonSD-10Nov22_16gb>certutil -hashfile emonsd-10nov22_16gb.img MD5
MD5 hash of emonsd-10nov22_16gb.img:
CertUtil: -hashfile command completed successfully.

Which means that this is likely the problem. I have redone the download from 3 different browsers and gotten the same result.

Is there another server I can get a download from ?? I also put the checksum for the .img file as well.


Hi Robert

Imeant to say that I did download the 21Jul21 file and the checksum is correct .

As well as this I checked the system and this time the emonhub service will start but the following services did not and will not start

This could be the issue. Earlier this year there were some problems getting the image to work on a PiZero. I think @TrystanLea and @borpin made some changes to the scripts that create the image to make it work. So the scripts now work but the image which was created with the scripts with the problem might not have been updated. At the time, there was a suggestion that a note be attached to the image information about possible incompatibility. Don’t know if this was ever done.

Given the 2020 image works, is it possible to do an update from that to get to the latest version? I don’t know the answer to that and can’t check. @TrystanLea @borpin is this possible?


Hi Lee, Robert & Simon

Even thou the checksum was wrong for the file I decided to take Robert’s suggestion and use another Imager ->Etcher Tool.

The rewsult was that everything works perfectly. Whilst I haven’t programmed all the feeds yet it seemlessly did a full update and all services are Green.

Thankyou everybody for your help.


[RPi Imager settings used were]

allow SSH
Username & Password
Configure wireless LAN
Local settings Australia - keyboard US [locale settings?]

(Moderator - RW)

1 Like

Hi John,
Good news that’s it’s working. I’m slightly concerned the checksum of the iso was wrong though.

I’ve just downloaded it again, and md5sum’ed it and you are indeed correct.
The published checksum is -
(.zip) MD5: d4d27fcc553996768366662709307dda
The newly computed checksum is -
lee@workstation:~/Downloads$ md5sum

Is the website just out of date (which may confuse newcomers), or more worryingly is a supply chain attack in progress?
Can @TrystanLea have a look please?

1 Like

I concur with the ‘out of date’ bit.
My MD5 checksums are zip: 271d8d502e822e3703500a5762519c1d
and 086880994862896534c4cd61a7625b1e for the extracted image (not that you need to extract it with Balena Etcher).

Brian (@borpin) pointed this out to @TrystanLea some time ago (February)
and I forgot to follow it up.

(My download is from 12th February.)

Hi Robert,

So the MD5’s are the same since early February, that’s something.
I just had a thought it may have been the MD5 of a previous version, but I’ve just checked and rather worryingly that not the case.

Did you read what Brian wrote back in February? What I infer from that is the “old” version was replaced after only a few hours/days, and the checksum wasn’t changed.

Ah, no, I missed that.
Was it @TrystanLea who replaced it? I hope so. :fearful:

Yes this will be my fault. I missed updating the MD5’s on the last update. I will get them updated.

1 Like

After a few days of writing/re-writing drive images, it appears the solution to the original problem is don’t change the user name if you’re using the Raspberry Pi Imager.
The user name is pi and must not be changed.

That’s why Etcher works. i.e. there’s no way to change the user name when writing the
image with Etcher.

It’s OK to change the other RasPi Imager options:

  • Enable SSH
  • SSH password
  • User password
  • Configure wireless LAN
  • Locale settings