Netatalk does not work

I tried to enable netatalk on my emonSD based RPI.
Unfortunately without success.
I installed netatalk in the same way as I successfully did on another RPI running raspberian.
What is different on emonSD?
emonpi does show up in my Mac OSX finder, but I can’t connect to it via afp.

Today I’ve updated netatalks to the current version 3.1.11, following this tutorial:
→ Well, netatalk v3.1.1 is starting with the same effect: no connection.

I checked the avahi daemon, whether afp is announced properly.
This looks correct: IP-address:540 for afp.

Nevertheless there seems to be a configuration issue, which prohibits a connection from my Mac.
The syslog does not contain any interesting information about netatalk.

Any idea is very welcome.

I’ve been spending a little time trying to install Netatalk… It is somewhat painful! Nothing works yet. Still trying!

Out of curiosity, what version of Mac OS X are you using? If it is a somewhat current version you may want to install SAMBA instead. It is MUCH easier!

Hi Jon,

actually I don’t care whther AFP or SMB is working in th ebackground,
as long as it is announced correctly via avahi.
Due to convinience I would like to see emonPI to appear directly in the finder’s sidebar.
So I will give SAMBA a try…

Thanks for the hint.

That’s one notch short of heresy on an Apple product, isn’t it Jon? :smiling_imp:
Couldn’t pass it up. Have a good one!

It might be!

Mac OS X (macOS) seems to be moving away from AFP. I searched for an “official” AFP declining tech notice from Apple, but I could only find lots of rumors or hints. And Apple seems to be trending to something SAMBA-ish (according to the rumor mill).


Yes, SAMBA does appear in the Finder sidebar. This is SAMBA installed on home assistant on a RasPi 3B:

EDIT: Keep in mind access privileges are as the “pi” user. There will be files you cannot edit (i.e., no “sudo”)

Also SAMBA does simply not work on my emonSD (emonpi).
I have no idea what’s wrong.
It does show up in Finder, but a smb connection is not possible.
I compared my installation steps with a standard raspbian installation.
All fine with raspbian, but no luck with emonSD.
What is the difference?
Does the read only FS make a difference here?


By the way, yes I did check/disable ufw.
The firewall is not blocking connections.

What errors are you seeing? Screenshots would be great!

Were there any errors during install? If yes, what are the errors?

Read the last post in this topic. It may help.

for what it is worth

In my network I use nfs sharing between my macs and the different nas devices hanging around the house. I found samba way to slow in transfer rates … NFS is a little more delicate (read difficult ?) to setup but once there, files fly back and forth.

Never used it on raspberry but for sure it must be possible

I’m a great step further, but still confused!
@Jon I followed your hint, which may helped.
After some further testing, tried to establish the connection manually instead via Mac’s finder.
And see, “cifs” instead of “smb” does the trick.
On the termial this works for me:
mount_smbfs //[email protected]/pi ~/smb/
Alternatively I can mount via “connect to server”, by requesting cifs instead of smb cifs://emonpi/pi

But how do I manage to connect via the finder?
It is possible! It is working in connection with a standard raspbian installation.
Where is the difference for emonSD?

using your screen shot from above:
Double-click on the pi icon.

What happens when you double-click on pi? What do you see?

You should see a standard Mac network login window OR maybe this finder window:

Hi Jon,

the host “raspi2” is my raspbian reference, which is working.
“emonpi” is the one, which hurts me.
The shares aren’t shown for this one by default.
They only show up, if mounted manually.

Take a look at the SAMBA configuration file on the raspi2 (the raspbian reference). It should be located at /etc/samba/smb.conf.

Then take a look at the SAMBA configuration file on the emonpi. It should be located in the same location at /etc/samba/smb.conf.

   comment = Network Logon Service
   path = /home/samba/netlogon
   guest ok = yes
   read only = yes

I am guessing the above section is missing in the emonpi SAMBA config file.

Here is a quick example:

  path = /home/pi
  browsable = yes
  read only = no
  writeable = yes
  guest ok = no
  create mask = 0777
  directory mask = 0777

There are lots of example in the smb.conf file (and many others on the internet). Make sure you pick what you need.

You’ll also want to pick a password for the SAMBA pi user with:

sudo smbpasswd -a pi

And then restart SAMBA with:

sudo service smbd restart

Hi Jon,

during my tests I copied smb.conf from raspi2 to emonpi.

when you typed in:

sudo smbpasswd -a pi

did you add a password? The finder connection does not work with no password.

Yes, a password for smb is set.
I’m wondering how to convince the finder to use cifs instead of smb.
I could imagine that finder stores some parameters of hosts, so it behaves differently for them.
Announced bonjour services are equal.
Maybe I spend the time to sniff the packets during connection establishement with wireshark, but analysis might be time comsuming.