Community
OpenEnergyMonitor

Community

My Electric Bar Graphs

Hello,

I have emoncms 9.8.31 running on Centos 7.

I have written a c# applicaton to collect data from my Solar inverter over RS485 and send 9 inputs of data to the emoncms installation. (Inc Live W, Daily kWh, Total kWh)

I have got the following PHPFINA feeds: Live W, Daily kWh, Total kWh
I have also PHPTIMESERIES feeds: Daily kWh Max, Total kWh Max
(All values show positive, I have over 24 days of data on these streams)

I have tried to set up the my electric app to show just solar generation on an android phone, and also on the emoncms web page (will do the full my solar next)

The live power graph is working on both the web page and the Android app, but the daily bar graph is causing problems.

On the both the web page app and Android app, if I select the PHPFINA Total kWh stream and it will not show any bar graph.
If I select the PHPTIMESERIES Total kWh stream on the android app and the bar graph shows daily usage as expected.

I have today just added another stream to generate kWh from the live W stream to see if that makes a difference, but initially it hasn’t (but then it only has 8 hours of data).

I know there are no updates from the inverter overnight as the whole inverter turns off when it is dark.

Any ideas?

Thanks

Ian

Further to the this, even though there is a distinct kwh output from the inverter, using a new power to kwh seems to have made a difference in some places:

Using power to kwh stream has resulted in the iPhone app working (I didnt mention this previously as I assumed they were separate issues).

Using power to kwh stream has resulted in the Android app working, ok with new data so it is not showing history yet! But, it is showing the 1.7kWh generated today in the top right hand corner, the 829w currently being generated in the top left, and a bar graph showing 1.7 at the bottom of the page for today.

The power to kwh stream on the app on my emoncms web page does not seem to have helped, is showing the 829w currently being generated in the top left, but it is showing 0.0kWh today in the top right, and nothing on any bar graph at the bottom (all 3 apps, iOS, Android and emoncms webpage are all configured to use the same 2 streams).

I know I havent quite got 24 hours of data in the power to kwh stream yet, so I will keep an eye on it and confirm tomorrow if that starts working on the web page.

Thanks

Ian

After waiting overnight:

  • The iOS version works, the total today in the top right shows the incrementing counter and the bar graph on the bottom just shows previous days but not an increasing graph for today

  • The Android version is different but still works, the total today in the top right shows the incrementing counter and the bar graph on the bottom shows previous days AND an increasing graph for today

  • the emoncms webpage version, shows the total today as the actual total for yesterday, and the bar graph to match. It is only the the live usage graph and the live power that are actually for today.

Any ideas what is going wrong?
Thanks

Ian

It seems to have been related to my PHP installation and how the version was handling the arrays used for calculating daily usage.

It was running webtatic PHP 7.1, and for other reasons I have just updated to the remi PHP 7.3 (beta).

All problems have just gone away and it operates as expected.

5 posts were split to a new topic: Getting data from inverters via an RS485 connection