Huzzah dead after flashing new firmware

Unfortunately I forgot the password for my EmonESP I set up a couple of month ago. So I decided to flash a new firmware to the ESP but after flashing was completed my EmonESP seems to be dead or stuck in bootloader Mode (red led in permanent dim). Ive tried to upload the unmodified firmware.bin and spiffs.bin (tried both) from GitHub but that changed nothing.
I am using the ArduinoIDE and the Esptool on my windows machine. Programmer is FTDI232
Is there a way to get my Huzzah to work again?

I just tried uploading the firmware again using python on my windows computer. I tried the upload in once methode “ write_flash 0x000000 .pioenvs/emonesp/firmware.bin 0x300000 .pioenvs/emonesp/spiffs.bin” (I modified the path to my binaries)
That worked for me so far. After flashing and reset via RST I’ve connected the ESP to my EmonTX. But nothing happens. No LED, no network showing up…
The fact that the ESP accepts the programming tells me that the ESP is still working, right?!

Have you tried using esptool to completely erase the flash contents?
i.e. all flash contents vice just the program area.

Yes, I have used the
“ write_flash 0x000000 blank_1MB.bin 0x100000 blank_1MB.bin 0x200000 blank_1MB.bin 0x300000 blank_1MB.bin”
command to erase all flash contents. After this I re-flashed the firmware and the spiffs…
Didn’t help at all… Same as before… No light, no network. Also holding down the reset button while powering on the unit to force AP Mode did not work


doesn’t appear to be the same problem - but have you seen that thread?

Somehow, I don’t know why the Huzzah started working again afters round about 10 flash-cycles… I always flashed the firmware and the spiffs using my FTDI at 57600 baud.