Community
OpenEnergyMonitor

Community

emonSD-29Mar16 fail to update to 9.8.8

Hello
I am using an emonbase with low-write 9.8.7 and emonSD-29Mar16. So far I have kept updated the system with no problems. While upgrading to 9.8.8 I got the following message :

Start emoncms update:

Emoncms update started
Update script V1.1.0
Tue 15 Aug 00:30:12 CEST 2017
#############################################################
emonSD version: emonSD-29Mar16
ERROR: emonSD base image old or undefined…update will not continue
See latest verson: https://github.com/openenergymonitor/emonpi/wiki/emonSD-pre-built-SD-card-Download-&-Change-Log
Stopping update

Can anyone help me on upgrading the system ?
THX

I believe you’ll need to update to a more current image: Your image is emonSD-29Mar16 and the current image is emonSD-07Nov16.

Glyn @glyn.hudson should confirm before going through this process.
 

Thanks for your reply.
Is there any instructions on how to upgrade a running image or is it necessary to make backup , erase running image, install the new one and restore backup ?

There is no upgrade for a running image. You do need to make a backup, create the new image, and restore backup.

I’d suggest saving your current SD card as a backup and locating a new or gently used SD card for the emonSD-07Nov16 image. If something goes wrong then you’ll have the original.

Somewhere on the OEM site there are migration instructions for making a data backup with your current running image. Getting the new image written to a blank SD card using Etcher, and then importing the data to the new image. I’m having trouble locating that info at the moment! :thinking: :thinking:

You may want to look thru the Guide and the Resource areas. I’ll repost if I stumble across the info.

I will definitively follow your suggestion to use current sd card as backup.
Thanks a lot for your time

Do you suggest to run periodically a “sudo apt-get dist-upgrade” command after installing emonSD-07Nov16 image to keep linux base system updated ?

After installing emonSD-07Nov16 - Yes. But I don’t run periodically update/upgrade. I usually leave update/upgrades for when I am upgrading lots of other things (e.g., node-red, etc.) and I have time to spend on any issues. And after doing a backup!

I see your suggestions. Thanks again for your consideration.

topic closed with success.

Shortly :

  • installed emonSD-07Nov16 on new 32GB sd card following OEM guide
  • waited very long long time to expand fs size using emonSDexpand script
  • performed an update/upgrade
  • restored previous backup
  • manual copied nodered flows && performed a nodered restart
  • low-write 9.8.8 | 2017.07.18 running confirmed
  • all is working
1 Like